• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1046
  • Last Modified:

Remote Desktop Black Windows

I have a Windows 2003 Machine where anytime a new user logs into the server they get black windows. The desktop seems to come across fine, but any windows that appear are blacked out. Using the same RDP client and same settings, I can login into the same machine using a different account and everything appears the way it should. Attached is a picture. This is what I have done so far but to no avail. I have turned off "persistent bitmap caching" and I have followed the instructions as well.

http://theregime.wordpress.com/2010/02/15/rdp-black-screenconsole-black-screen-or-parts-black-windows-2003/

Any other ideas?
Black.jpg
0
jhakie
Asked:
jhakie
  • 7
  • 5
  • 2
1 Solution
 
Timothy McCartneySYS ADMINISTR I INFRASCommented:
Based on what you've said, it's definitely a profile based issue. These types of things (unless it's a quick fix) I usually fix just by recreating the user's profile.

To do so, make sure said user is LOGGED OFF.
While you're logged in as an administrator, go to Documents and Settings, and rename the user's folder to "Documents and Settings/userfolder.old"

Then log back in with the desired user. You should see a clean desktop with minimal icons. Once you've successfully and completely logged in, log back off again and go back to the administrator account. Now in Documents and Settings you should see two folders for that user. "Userfolder" and "userfolder.old". Copy the contents from the .old folder to the newly created one (i usually just copy outlook files like the .NK2 file, .PST if using something other than exchange, Favorites folder, Documents, and any other "Personal" data the user may need).

This eliminates most profile based issues I've ever come accross. This is usually much quicker to reset up a profile than it is to diddle endlessly trying to correct a simple, yet annoying problem.
0
 
jhakieAuthor Commented:
Thank you for the comment, but I have done this too and it has not fixed the issue. I just did this again to make sure and it does not solve the issue.
0
 
Timothy McCartneySYS ADMINISTR I INFRASCommented:
What happens if you create a brand new account and log in?
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jhakieAuthor Commented:
Same thing. It seems that any new account domain or local that we use has this same affect.
0
 
jhakieAuthor Commented:
I just deleted a profile off this machine that was working and logged back into the server using that same account. I now get the black windows using this account now. So it has to be something that is corrupt in the system that affects the way the new profiles are being setup. This is really annoying.
0
 
sjklein42Commented:
I'm guessing something is wrong with the Remote Desktop settings in the Registry.  Investigating.
0
 
sjklein42Commented:
This is the key where all the Remote Desktop settings are stored.  You may want to take a look at it with regedit.  Maybe compare to a system that works.  Sorry I can't be more help.

HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client

Open in new window

0
 
Timothy McCartneySYS ADMINISTR I INFRASCommented:
I would look for the troublesome registry key ON the server, doesn't sound like this problem is being dictated by any of the local workstations.

Maybe try using an alternate RDC program to see if you get the same results?

There is a program called "Cord" mentioned in the thread below. Seems promising

http://ask.metafilter.com/69316/Why-do-I-get-a-black-screen-when-using-Remote-Desktop-Connection
0
 
Timothy McCartneySYS ADMINISTR I INFRASCommented:
http://cord.sourceforge.net/ < this is the link to the program "Cord" as mentioned above if you want to give it a shot.
0
 
Timothy McCartneySYS ADMINISTR I INFRASCommented:
woops....

Please disregard the above... Just realized Cord is used on a Mac based computer... I'll keep looking.
0
 
Timothy McCartneySYS ADMINISTR I INFRASCommented:
Just found these two links... Seems promising.

http://www.winserverkb.com/Uwe/Forum.aspx/windows-ts/14790/remote-desktop-black-screen <- Check the very last post on this forum

http://support.microsoft.com/?kbid=906510 < - Link posted on the above forum to a Microsoft KB that may help you.

I believe the issue is your "Default User" profile is corrupt.
0
 
Timothy McCartneySYS ADMINISTR I INFRASCommented:
Below is the last post as mentioned in my previous comment (so you don't have to navigate and search for it.)

"And in case it happens to all new users (meaning your default user
profile is corrupt), then you can find the correct values for the
colors here:

906510 - The logon screen turns black after you press
CTRL+ALT+DELETE to log on to a Microsoft Windows Server 2003-based
computer
http://support.microsoft.com/?kbid=906510

Note that the .default registry hive is *not* the default user
profile, so you can't use the solution described in the article as
it is.
You can load the Default User hive, which is the file C:\Documents
and Settings\Default User\ntuser.dat"
0
 
jhakieAuthor Commented:
I solved the issue by doing this again:

http://theregime.wordpress.com/2010/02/15/rdp-black-screenconsole-black-screen-or-parts-black-windows-2003/

When I exported the "good" key I placed it on my the desktop of the profile I was having issues with, ran the reg key and it installed it on the bad profile. Logged off and then back on again and it worked.

Thanks for all the help.
0
 
jhakieAuthor Commented:
The exported Reg file from a working profile worked great.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 7
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now