• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 346
  • Last Modified:

Sorting in SharePoint

If you look at the attached picuture you can see how sharepoint is sorting my documents. I need it to sort by more digits than it is.  

I dont want it sorting like


I need 02-65 Above 02-100 if that makes since. If not please let me know.
2 Solutions
I had the same issue. It's all in the sort setting unser site actions. Take a look at this link, it gets you to the area you need to adjust the sort settings.

Sharepoint is considering this field as string and sorting it on String basis only, i.e. why u r not getting ur desired results (Bcoz Name is a mix of string & int).

I don' think u will be able to modify this sorting behavior in SP, instead u can try creating another column based on this Name column and sort basis on that custom column.

rstahl08Author Commented:
Looking at your link want I need to enable Publishing Features.  Unfourtanly that feature is only in MOSS 2007-10. Not 3.0, so I guess I need to seek approval for 2010 purchase :-)
I think  navtej dhillon is right- we had a similar problem with a document library for meeting documents, where the documents needed to be listed in the order they appeared on the agenda.  We created a column called Agenda Order of type number and used it to sort the items in the library.  
rstahl08Author Commented:
I will justy have to play around with it. Thank you!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now