Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1588
  • Last Modified:

Attachment limit OMA 2003

We have a SBS 2003 R2 server with OMA. The limits are set to 60 MB in the Exchange System Manager, but using an OMA client, an e-mail attachment of more than 4 or 5 MB won't work.

When looking for an answer, i find these articles for Exchange 2007, where the web.config parameter maxRequestLength value has to be modified. But  looking for something alike for 2003, i can't find it.

Who can help me out?
0
hanrat
Asked:
hanrat
  • 10
  • 3
  • 2
  • +2
1 Solution
 
praveenkumare_spCommented:
We can do a global setting , but i am not sure of a per mailbox setting
0
 
hanratAuthor Commented:
I'm looking for a global setting, ofcourse.
0
 
praveenkumare_spCommented:
in 2003 we cant restrict the size of the attachment, but we can restrict the size of the messaage .

So we can indirectly reduce the size of the attachment using these changes . let me know if thats fine ?
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
hanratAuthor Commented:
Yep, that's AOK! As long as it concerns OMA with Mail for Exchange clients.
0
 
praveenkumare_spCommented:
check for the  "Set Delivery Restrictions"
in this KB  

 http://support.microsoft.com/kb/821881
0
 
hanratAuthor Commented:
Dear praveenkumare_sp,

I'm looking for a global setting for OMA. This setting does not apply to OMA nor Mail for Exchange. Why do you think this setting will help me?

Hans
0
 
hanratAuthor Commented:
It's not helping because i'd already have limits up to 60 MB, as mentioned in my opening post and the Mail for Exchange clients can't send large e-mails.
0
 
Glen KnightCommented:
first I think we need to understand your problem.

MailforExchange (nokia)
ActiveSync (google android, ipad/iphone, windows mobile)

All use ActiveSync, they also have their own limits on the device themselves.  Exchange 2003 uses it's organisational limits for all services, these cannot be changed on an individual service basis (as far as I am aware).  if you have set the organisational limit, then the issue is with the device itself.

Not only that, if it was Exchange rejecting your message it wouldn't strip the attachment off, it would send you an NDR telling you it's too big.
0
 
hanratAuthor Commented:
Hi Demazter,

Thanks for your questions. It concerned both a Nokia, HTC and an iPad. I found these articles for Exchange 2007 OMA, where it is the limits of the IIS cache that's involved in this matter. As OMA 2003 also uses IIS i expect more or less the same issue here.

Looking for limits in ActiveSync i find other saying there are none. As we have the same limit with 3 devices, it feels to me like a server sided limitation.

I'm asking the user for specific error messages.

Thanks!
0
 
hanratAuthor Commented:
The user does not receive an error message. In the Mail for Exchange client on the Nokia, the message moves to the sent items box and is never received by the recipient.

How to trouble shoot this?
0
 
Glen KnightCommented:
I am not aware of anywhere to set such a limit with Exchange 2003.  I am going to build an Exchange 2003 server now so I can test this for you.
0
 
Craig BeckCommented:
There's a registry key which controls the ActiveSync attachment maximum size limit.

!!!BACK UP THE REGISTRY FIRST!!!

Open Registry Editor on the Exchange Server and navigate to the following key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA

Create a new DWORD value named MessageSizeLimit.
Set the value in Kilobytes, so if you want to limit the maximum attachment size to 1MB you would set the value to 1024.
0
 
hanratAuthor Commented:
Hey Craig,

That really sounds promising! Will an IISReset be enough or do i have to restart the server to take changes into effect?

Kind regards,

Hans Rattink
0
 
hanratAuthor Commented:
Yeah!! After an iisreset it worked... Great! I'd put it to 20480 and could sent an e-mail with a file attacment of 12 MB!

Thanks a really lot, Craig!
0
 
hanratAuthor Commented:
Finally somebody who actually knew the answer. Also thanks to the moderators for bringing my question twice to the attention of the experts.
0
 
Outsourced2CoudCommented:
Wow, same problem, IISRESET doesn't do, I will try a reboot tonight, did you also try the UploadReadAheadSize setting in Web Config for this to work, I wonder if there is one other tweak you have done that I am not aware of?
0
 
hanratAuthor Commented:
Hi O2C,

Sorry for the late answer. I didn't try the UploadReadAheadSize, the other just worked for me. Please mind that all other settings in the Exchange System Manager where set ok, to about 60 MB.

Kind regards,

Hans
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 10
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now