Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Auto-discover broken for ActiveSync and Not RPC/HTTP

Posted on 2011-03-08
22
Medium Priority
?
1,078 Views
Last Modified: 2012-05-11
Hello

I am attempting to set up a Multi Tenant Exchange hosted environment. I have gotten most everything to work EXCEPT ActiveSynch + AutoDiscover.

AutoDiscover doesn't seem to work with it, yet it works with Outlook Anywhere.

Attached is  my EXCA log in PDF format...


VHSLI = Hosted Services Domain (Where the server is)
VCSLI = The domain which is being hosted.
Microsoft-Exchange-Server-Remote.pdf
0
Comment
Question by:VCSLI
  • 12
  • 10
22 Comments
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35077515
but if u give the settings manually does activesync work
0
 

Author Comment

by:VCSLI
ID: 35077875
Yes. It asks me to accept an un-trusted SSL cert, but it does work.

I'm trying to get AutoDiscover to work properly though...
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35083702
what is the version of  ur phone and exchange server
0
Lessons on Wi-Fi & Recommendations on KRACK

Simplicity and security can be a difficult  balance for any business to tackle. Join us on December 6th for a look at your company's biggest security gap. We will also address the most recent attack, "KRACK" and provide recommendations on how to secure your Wi-Fi network today!

 

Author Comment

by:VCSLI
ID: 35084208
Exchange 2010 Ent running in /hosting.

iPhone 3GS w/ 4.2.1

Androud EVO Thinger.

0
 

Author Comment

by:VCSLI
ID: 35085172
Playing aorund a bit more i get this...

 EXCA3.pdf
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35086121
do u have the URL https://autodiscover.vcsli.com available externally ?

if yes is a valid certificate accosiated with the URL

By the error msg it says a valid certificate is not present
0
 

Author Comment

by:VCSLI
ID: 35086150
This is a hosted Exchange. I'm using the redirect method to circumvent this need.

I have fixed some things but i have a new issue. Please see attached log.


ALMOST-THERE.pdf
0
 

Author Comment

by:VCSLI
ID: 35087013
Ok, It seems it was an issue with the authentication methods allowed.

I am now trying to correct this one last error...

Any help would be appreciated.
Untitled.jpg
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35087135
as this fails here
The Exchange ActiveSync URL was in an invalid format. It should be https://host/Microsoft-Server-ActiveSync. was https://vhsli-ex-01.vhsli.local/.


please check the internal and external URL for Activesync in EMC

GO to EMC > server config> Client Access> in the mid plane select Activesync and see the info of the same
0
 

Author Comment

by:VCSLI
ID: 35087146
Already fixed that.  :P

Am not having the issue shown in my screenshot.

      Testing HTTP Authentication Methods for URL https://mail.vhsli.com/Microsoft-Server-ActiveSync/.
       The test passed with some warnings encountered. Please expand the additional details.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       The following authentication methods are enabled, but they aren't allowed authentication methods for this service. Methods: Negotiate, NTLM
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35087195
Basic authention must be enabled for Activesync VD
0
 

Author Comment

by:VCSLI
ID: 35087246
Here are my settings for that VD

If i disable Windows Authentication and Enable Basic, the connection fails.

If i disable Basic and  enable  Windows Auth the connection works.
Capture.PNG
0
 

Author Comment

by:VCSLI
ID: 35087371
Here is a screen cast to show you.
VCSLI-419224.flv
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35087475
Even though this is not needed
please disable the NTLM(windows) and check
0
 

Author Comment

by:VCSLI
ID: 35087479
I did. It fails. Please watch my video.
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35087513
Even though this is not needed
please disable the NTLM(windows) and check


do IISRESET before testing it
0
 

Author Comment

by:VCSLI
ID: 35087554
Disables Windows Auth

Left Basic Enabled

performed iisreset

Ran test again and it still fails.

Right now i have Basic Enabled and Windows Auth disabled. My outlook client wont connect also.
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35087576
UR outlook is no way connected with Microsoft-Server-ActiveSync Virtual Directory
0
 

Author Comment

by:VCSLI
ID: 35087590
I agree. However i just enabled it and did another IISReset. My outlook client now connects.

I can make another screen cast if you want and show you.
0
 
LVL 8

Accepted Solution

by:
praveenkumare_sp earned 2000 total points
ID: 35087681
no thats fine ,,

just check whether activesync is working fine on a device now?

Dont fully depend on EXCRA as its not always correct

0
 

Author Closing Comment

by:VCSLI
ID: 35208399
It's been working fine. EXCA still complains about the auth types and that they are un-needed... Not sure how to fix that. It doesn't seem to be an issue though.
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35209938
its good to hear that Activesync is working :)
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Internet has made sending and receiving information online a breeze. But there is also the threat of unauthorized viewing, data tampering, and phoney messages. Surprisingly, a lot of business owners do not fully understand how to use security t…
Eseutil Hard Recovery is part of exchange tool and ensures Exchange mailbox data recovery when mailbox gets corrupt due to some problem on Exchange server.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
Suggested Courses

971 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question