Solved

Outlook 2003 Search function works for some users, not for others

Posted on 2011-03-08
13
1,427 Views
Last Modified: 2012-05-11
We are running Exchange 2007 SP2 (Rollup 4) on Windows 2008 servers.  The Exchange version is 08.02.0254.000.  Clients are running Outlook 2003 on Windows XP computers.

We recently started getting complaints from some users that their search function in Outlook stopped working.  They enter a word in the Find window that they know is in the subject of a message, but the search does not find anything.  This is only happening for some users and not others.

When I run the command Test-ExchangeSearch -identity <user id> on the Exchange 2007 mailbox server, it results in "False" for the people who are having this problem, and "True" for those who are not having the problem.  It appears that all the users who have this problem all have mailboxes on the same Exchange mailstore.  For users with mailboxes on the other mailstores,  the search fuction is working correctly.

Thanks very much for any assistance!
0
Comment
Question by:SerendipityToo
  • 4
  • 3
  • 3
  • +1
13 Comments
 
LVL 33

Expert Comment

by:digitap
ID: 35118977
there is sp3 for exch 2007. have you considered installing that yet?
0
 
LVL 41

Expert Comment

by:Amit
ID: 35123224
Looks like index issue for that database. Rebuild the index again for that db.

Check below links, talks about same issue
http://www.conetrix.com/Blog/post/Exchange-2007-Indexing-Issue---Outlook-Not-Returning-Search-Results.aspx
0
 
LVL 41

Expert Comment

by:Amit
ID: 35123226
0
 

Author Comment

by:SerendipityToo
ID: 35123682
Amitkulshrestha:


I'm sorry for the delay in responding.  I haven't had access to a computer this weekend, so I'm using my mobile phone.

I had seen the article that has the Test-ExchangeSearch command.  That's where I picked that up and found that all the users with a problem were on the same database.  I wasn't sure about the solution in that one because it talked about installing Service Pack 1, which is in the past.

It looks like the other link you sent, with the suggestion to delete the index catalog file, will be the solution for me.  I won't be able to try it at work for 2 or 3 days, but if it works, I will definitely come back and award the points.

Thank you so much for helping me!
0
 
LVL 33

Expert Comment

by:digitap
ID: 35123846
@SerendipityToo :: being up to date on your service packs is important too as i suggested here, http:#a35118977. you indicate in your question that your Exchange 2007 server is on SP2 rollup 4 and there is SP3 available now.

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=1687160b-634a-43cb-a65a-f355cff0afa6&displaylang=en


Good Luck!
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 41

Expert Comment

by:Amit
ID: 35127926
Hi SerendipityToo

Thanks for the update. Take your time, and let me know, if you face any issue.

Thanks
Amit
0
 

Author Comment

by:SerendipityToo
ID: 35131892
digitap:  Thank you for the reminder for updating the service packs.  When we get very busy, this kind of update tends to slip down the priority list, but I do need to make it a higher priority.  I see that Service Pack 3 updates the MSSearch process.  Since our current problem is only on one out of four databases, I'm going to try the suggestion for rebuilding the index first.

amit:  When I do the manual update procedure, am I correct that I should delete the entire folder with the name starting with "CatalogData-" that is under the problem database, or am I supposed to delete only the files contained in that folder?  If I delete the entire folder, will the folder be recreated automatically with the correct name when I restart the MSSearch service?

Thank you!
0
 
LVL 33

Expert Comment

by:digitap
ID: 35135085
sounds good.
0
 

Assisted Solution

by:AGS
AGS earned 100 total points
ID: 35136457
If Test-ExchangeSearch returns Result = false or time -1,  the intdexer is not working properly. Solve your Exchange Index problem before.
To do this, ensure that all your database are index enabled ( use "get-Mailboxdatabase | fl name,indexenabled ).
Then executa the script "ResetSearchIndex -all -force" ( the script is located in %PROGRAMFILES%\Microsoft\Exchange Server\scripts ). This command will ask you to confirm delete the actual catalog , and a reindexing work will begin.
When the reindexing is finished ( run test-exchangesearch again ), the script will show a "true" result and its searchtime.
Then check the Outlook search again.
It your are running your Outlook in cache mode, disable it in order to check if this is the problem.
If yout test-exchangesearch fail again, try to stop services ( Microsoft Exchange Search Indexer and Microsoft Search ( Exchange ) ) , and reregister manually the dlls. ( msfte.dl , msfteproxy.dll ans MapiProtocolhandlerstub.dll ) , then start the services again and re-run the "resetSearchindex" again.
0
 
LVL 41

Accepted Solution

by:
Amit earned 400 total points
ID: 35136543
There are two ways to do this task.

First to use the ResetSearchIndex.ps1
Second to use manual method. In this you need to first stop the MSExchangeSearch service, delete the Catlog directory and start it again. For more information please refer to below article

http://technet.microsoft.com/en-us/library/aa995966(EXCHG.80).aspx

0
 

Author Closing Comment

by:SerendipityToo
ID: 35152842
Last night I used the manual method on the specific database that was having the search problem, and then decided to run the script to rebuild the indexes on all four databases.  The Outlook Search works great now for everyone on all databases.

I awarded the bulk of the points to Amit because he was the first to point me in the direction of rebuilding the search index and provided me with links to information that worked for me.  I also gave points to AGS because of the additional information provided, and I did use the command to verify the databases were all index enabled.

Thank you very much to everyone for helping me solve this problem!  Experts Exchange is a wonderful resource.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Sometimes Outlook might have problems sending a message. There may be various causes- corrupted PST, AV scanner etc. The message, instead of going to the Sent Items folder, sits in the Outbox indefinitely. To remove it you can use a free tool cal…
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now