Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Apache cannot start, unable to load module mod_ssl

Posted on 2011-03-08
8
Medium Priority
?
4,953 Views
Last Modified: 2012-05-11
I have recently installed a new apache webserver on my red hat linux server. It was working fine on port 2345. I have recently tried to enable https on it and added the required parameters like below, since when apache is not starting. It gives the error,

--------------------------------------------------------------------------------------------------

httpd: Syntax error on line 43 of /apps/elsdev/apache/conf/httpd.conf: Cannot load /apps/elsdev/apache/modules/mod_ssl.so into server: /apps/elsdev/apache/modules/mod_ssl.so: wrong ELF class: ELFCLASS32

--------------------------------------------------------------------------------------------------


LoadModule ssl_module /apps/elsdev/apache/modules/mod_ssl.so

<IfDefine SSL>

  SSLEngine on
  SSLCertificateFile /apps/elsdev/ssl/sabweb-dev-02.cer
  SSLCertificateKeyFile /apps/elsdev/ssl/server.key
  SSLCertificateChainFile /apps/elsdev/ssl/TEST_SSL_CA.cer

</IfDefine>

Versions info::

Apache webserver: httpd-2.2.17
Red Hat Linux         :

$ uname -a
Linux web-dev-02 2.6.18-128.1.14.el5 #1 SMP Mon Jun 1 15:52:58 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Please let me what I am doing wrong?
0
Comment
Question by:Raz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
8 Comments
 
LVL 92

Expert Comment

by:objects
ID: 35078572
looks like a 32 bit module installed on a 64 bit system
0
 
LVL 3

Expert Comment

by:VespaMaru
ID: 35078632
Is SELinux turned on?  If so you may need adjust for the SSL cert files.
0
 

Assisted Solution

by:Raz
Raz earned 0 total points
ID: 35078652
Also I have added a recent version of mod_ssl and tried. It gave me error

httpd: Syntax error on line 43 of /apps/elsdev/apache/conf/httpd.conf: Cannot load /apps/elsdev/apache/modules/mod_ssl.so into server: /apps/elsdev/apache/modules/mod_ssl.so: cannot read file data: Is a directory

mod_ssl version : mod_ssl-2.8.30-1.3.39

How to determine a module 32 bit or 64 bit?
I think my linux server is of 64 bit. so where can I get a 64 bit module?
Please provide me the links.
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 

Author Comment

by:Raz
ID: 35078656
How to check SELinux turned on or not?
0
 
LVL 3

Expert Comment

by:VespaMaru
ID: 35078768
getenforce command will tell you.

As objects said though, get the 64bit module first.

http://www.ioncube.com/faqs/loaders.php#7aa  

You can compile it from source http://www.modssl.org/source/ or better yet, download it from the Red Hat repository.

0
 

Accepted Solution

by:
Raz earned 0 total points
ID: 35079628
I have downloaded 64bit module from,

http://pkgs.org/download/centos-5-rhel-5/centalt-x86_64/mod_ssl-2.2.17-1.el5.x86_64.rpm.html

and tried to start apache. I got another error,

httpd: Syntax error on line 43 of /apps/elsdev/apache/conf/httpd.conf: Cannot load /apps/elsdev/apache/modules/mod_ssl.so into server: libdistcache.so.1: cannot open shared object file: No such file or directory

Please help!!
0
 

Assisted Solution

by:Raz
Raz earned 0 total points
ID: 35079665
I think I have downloaded a module for centos.

Please provide me a url where I can get 64 bit module for linux...!!
0
 

Author Closing Comment

by:Raz
ID: 35174491
the comments provided by the experts is not helpful.
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hi, in this article I'm going to teach you how to run your own site, and how to let people in (without IP). I'll talk about and explain each step... :) By the way, everything in this Tutorial is completely free and legal. This article is for …
If you've heard about htaccess and it sounds like it does what you want, but you're not sure how it works... well, you're in the right place. Read on. Some Basics #1. It's a file and its filename is .htaccess (yes, with a dot in the front). #…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
Suggested Courses

660 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question