• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2542
  • Last Modified:

How to remove server name appended to Exchange 2010 SMTP message header content-type boundary

Exchange 2010 help clearly states that SMTP message header removal or re-writing for content-type boundary is not possible through a transport rule and for good reason - message encryption etc..
   http://technet.microsoft.com/en-us/library/aa996806.aspx

So how do you get Exchange to exclude the server name and domain name at the end of the unique id in the first place.

This question has been asked in TechNet and no answer was provided.  However, it does highlight that in some installations the server and domain is appended and in some installations it does not.
http://social.technet.microsoft.com/Forums/en-US/exchangesvrtransport/thread/8139f4ed-2c44-4b7c-9526-f08f48180db0

The issue is highlighted in the SMTP message header below.  The reason for wanting to hide the server and domain information is that we provide email for three different domains and don't wish to link them.

Subject: hi
Thread-Topic: hi
Thread-Index: AcveAJ172eb6O/YkQ/GrIX0R8PYMog==
Date: Wed, 9 Mar 2011 02:20:53 +0000
Accept-Language: en-GB, en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
Content-Type: multipart/alternative;
      boundary="_000_CB9E838BBA01344FAB96683C91CC0521E331ServerNameDomain_"
MIME-Version: 1.0

--_000_CB9E838BBA01344FAB96683C91CC0521E331iitServerNameDomain_
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

Any help much appreciated.
Thanks
0
Jon_Ws
Asked:
Jon_Ws
  • 5
  • 4
1 Solution
 
MegaNuk3Commented:
0
 
Jon_WsAuthor Commented:
The cmdlet Remove-ADPermission to remove the Ms-Exch-Send-Headers-Routing permission from the 'received', 'x-originating-ip' and other 'x-headers' that are used internally had been applied previously.   This removed other header items but doesn't help with the content-type boundary string setting.  Good suggestion though and should have put in the original question for completeness.
0
 
MegaNuk3Commented:
I was thinking it might not help with the content type boundary string, but worth testing.

Might be time to call MS... Depends how badly you want to do it.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Jon_WsAuthor Commented:
Thanks.  We're just getting the MS support agreement .... interesting that our Exchange 2007 solution did not have this problem.  A new feature for 2010.
0
 
Jon_WsAuthor Commented:
The content type boundary server/domain information seems to be set by the email client being used not the exchange server.  So the problem is noticeable with outlook, weboutlook but not Mac Mail and some other email clients.
This explains why the content type boundary string sometimes has server and domain and at other times not.
0
 
MegaNuk3Commented:
Interesting, thanks for update
0
 
Jon_WsAuthor Commented:
To avoid the issue rather than resolve it created a new domain in the forest and re-built the exchange server.  Authentication still works with the original domain and issue now less prominent.
0
 
MegaNuk3Commented:
Thanks for the update and final solution
0
 
Jon_WsAuthor Commented:
Nobody could come up with an answer so needed an effective work around.
0
 
davidsatCommented:
hi Mr. Jon, I have write a blog to how remove message header in exchange 2010, please check it out http://demagnum.wordpress.com/2011/12/30/remove-message-header-in-exchange-2010/ 
i hope my article get help issue in your exchange 2010.
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now