Home Network - Assistance Connecting Network on R1 with R2

Posted on 2011-03-08
Medium Priority
Last Modified: 2013-11-05
Hello Guys,

 I recently got Fios on my home network. They gave me a "Actiontec MI424WR-GEN2 Rev E router" / modem which also works as a wireless AP. the wireless sucks therefore I decided to use my own Router "DLink DGL-4500 Gamer" for wireless connections. After connecting the DLink Router to the Actiontec Router (given by my ISP) I was able to connect a host to the DLink and browse the internet fine. The problem is that on my DLink Router I am on a different network than on the Actiontec. I am able to browse the internet on both network with no problems but I can't ping or connect to any host on the other network and viceversa. I was wondering if there was a way of making these two Routers/Networks "talk" to eachother??

Actiontec Router: (ISP)
DLink Router: (Home)
Note: I can ping my default gateway which is from network 192.168.0.x using any host.
Question by:valdezf
  • 2
  • 2

Accepted Solution

DColclazier earned 2000 total points
ID: 35080345
An easy way you could possibly achieve this would be to configure the DLink DGL-4500 in Access Point mode rather than routing mode. If you can't configure it in an Access Point mode, make sure the following is true:

1) Network Address Translation(NAT) is turned off on the DLink Router
2) Add a manual route to the DLink Router - destination via gateway
3) Network Address Translation(NAT) is turned ON on the ActionTec

Another way to configure this would be to configure the ActionTec modem in a bridge mode - the Actiontec would not perform any DHCP, DNS, or Routing functions, but would be a 'pass-thru' modem that would pass all traffic through to your DLink. Then you would simply be working with the network.

Let me know how it works!


Author Comment

ID: 35080571
nice! that worked except that I can't ping hostnames just IP addresses. Same goes with mapping to shared drives, I would have to type the IP instead of the host name. Is there a way around this?

Adding manual Router: Destination is (DLink) and Route (ActionTec)
It asked me for a Metric and I added 1 - I guessed
There is an option for the DNS on DLink, this might be what I need to configure to fix the hostname issue. but I am unsure.

Author Comment

ID: 35080805
I fixed it by changing the "Local Domain Name" on the DLink Router. Thanks for your help!!!

Expert Comment

ID: 35084498
Happy to! Glad you got everything working :-)

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

607 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question