Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Applying Proxy Settings in GPO to Machine and not User

Posted on 2011-03-09
6
Medium Priority
?
1,214 Views
Last Modified: 2012-08-13
I have a problem that I can't seem to solve.

I want to use GPO's to configure IE. Mostly this works, the one area where it does not is with the proxy settings.  MS in it's "Wisdom" thinks that the only place one should be able to set the proxy settings is with the user...which is stupid since it's more likely that a user would move around and a PC would stay put.  But I digress...

I have found the setting in the Computer config section of the GPO where I can specify that proxy settings are per-machine and NOT per-user...supposedly.

I've found this to not be true.

I need two different proxy settings depending on where in the network the computer lives. Here was my plan.  I was going to create an OU specific for the PC location and apply the appropriate GPO, adding in the appropriate computers and a test user. So when I logged in as the test user both the computer config and user config portions of the GPO would execute; this works fine.

Then I was going to apply another GPO to the user OU that was configured with the user things that are global like home page and security settings. I assumed that it would NOT make any difference what was in the proxy setting since I had already applied the correct proxy setting when the config user had logged in and I had specified that proxy settings are per-machine and not per-user.  But whatever is in the user config section of the GPO assigned to the user OU overrides the original proxy settings.

How can I use GPO's to configure IE and make the proxy settings stick per machine?
0
Comment
Question by:jhyiesla
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 6

Expert Comment

by:Kody-Burg
ID: 35084693
How can I use GPO's to configure IE and make the proxy settings stick per machine?


The site below has a very good step-by-step guide to setting up group policy to apply proxy settings for IE:

http://nickganga.com/2009/03/13/internet-explorer-7-advanced-proxy-settings-via-group-policy/
0
 
LVL 28

Author Comment

by:jhyiesla
ID: 35084780
Had already found that site and tried what he suggested at the link you provided and no joy.
0
 
LVL 7

Accepted Solution

by:
lucifer82 earned 1500 total points
ID: 35109148
You can set the proxy using the command line tool:

http://support.microsoft.com/kb/900935/

so what you need to do is create a login script which first checks your ip and then if it matches the network that you want then apply particular proxy server details and at the end of the script you will need to set saying if other wise no proxy

Pseudo code

Check IP
 IF ip = XXX.XXX.XXX.XXX
 set proxy = site1.proxy.com
 ELSE IF ip = YYY.YYY.YYY.YYY
 set proxy = site2. proxy.com
ElSE
 set proxy = none
END IF
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 28

Assisted Solution

by:jhyiesla
jhyiesla earned 0 total points
ID: 35109900
lucifer 82, that would probably work, but I think our network is probably too complex to make that a useable solution.

I have kind of figured it out though.

I have two GPOs. One sits everything, user and computer config. The other just has user things in it and it was this second one that was causing the issue.  I found that in that IE Maintenance section of the user config, if you right-click on it there is an option to reset that whole section. So I did that and then reinput things that were missing like the home page URL.  BUT I just left the proxy settings alone. Now when I apply that GPO, what ever was placed there by the first GPO sticks.  Even though it just "looks" blank it's more like it's null, because I had tried blanking it and that just then blanked the proxy settings when I applied the GPO.  With this "null" setting, it seems as though it functions like a normal GPO setting of Not Configured.
0
 
LVL 28

Author Closing Comment

by:jhyiesla
ID: 35109908
Lucifer82's solution probably would have worked, but what I came up with seems more usable in my environment.
0
 
LVL 7

Expert Comment

by:lucifer82
ID: 35110309
Hi jhyiesla,

What's important is that you got a workable solution :)
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In threads here at EE, each comment has a unique Identifier (ID). It is easy to get the full path for an ID via the right-click context menu. However, we often want to post a short link within a thread rather than the full link. This article shows a…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question