• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 551
  • Last Modified:

xlsx files open with new name

I have an odd problem occurring on my laptop. I'm running WinXP SP3 and Office 2007.

When I open an xlsx file, it's opened as a new file. For instance, I have a file on my desktop called 'book.xlsx'. When I double click this file to open it, it's opened as 'book1.xls'. If I make any changes, it acts like it's a completely new file when I try to save it. Saving as 'book.xlsx' asks to overwrite. It doesn't happen with xls files or any other office 2007 extension.

Any ideas???
0
sillybell
Asked:
sillybell
  • 7
  • 7
1 Solution
 
Rory ArchibaldCommented:
If you open windows Explorer, choose Tools- Folder Options, then on the File Types tab select .xlsx files, and press the Advanced button, is the New action shown in Bold, or is the Open action bold?
0
 
sillybellAuthor Commented:
The New action is bold and I see where you're going so I made the open action default.

Now when I try to open, I get three error messages...

1. 'C:\Documents.xlsx' could not be found. Check the spelling of the file name, and verify that the file location is correct.

2. 'and.xls' could not be found. Check the spelling of the file name, and verify that the file location is correct.

3. 'settings\william\Desktop\book.xlsx' could not be found. Check the spelling of the file name, and verify that the file location is correct.

The location of the file is "C:\documents and settings\william\desktop\book.xlsx" Excel is breaking the location up into three different files and adding it's extension.

0
 
Rory ArchibaldCommented:
Did you have the Use DDE option checked in the properties for the Open action?
0
Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
sillybellAuthor Commented:
Yes
0
 
Rory ArchibaldCommented:
Then in Excel options, in the advanced section, is the option to "ignore other applications that use dynamic data exchange (DDE)" checked? If so, uncheck it
0
 
sillybellAuthor Commented:
It's already unchecked.
0
 
Rory ArchibaldCommented:
Ok - what was in the command line section of the properties for the Open action?
0
 
sillybellAuthor Commented:
There is no command line in the properties. I have...

Actions: &Open
Application used to perform action: "C:\Program Files\Microsoft Office\Office12\EXCEL.EXE" /e %1
Use DDE : Checked
DDE Message:
Application: EXCEL
DDE Application Not Running:
Topic: System
0
 
Rory ArchibaldCommented:
Remove the %1 from the command line
0
 
sillybellAuthor Commented:
Removed "%1". Still getting same error.
0
 
Rory ArchibaldCommented:
Can you double check it's gone? (has been known to reappear!)
0
 
sillybellAuthor Commented:
You're right. It's back. Everytime I remove it and go back in, it comes back.
0
 
Rory ArchibaldCommented:
Try changing the %1 to "%1"
if that doesn't work, we may need to do a manual registry edit, but it would also be worth trying office diagnostics ( in the resources section of Excel Options)
0
 
sillybellAuthor Commented:
Thanks rorya!!!! That did it!!!
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now