Solved

Acquire DHCP address before Windows Login

Posted on 2011-03-09
20
2,034 Views
Last Modified: 2012-08-16
I noticed that when users log on to a windows joined domain pc, the network card is circling acquiring a dhcp address after logon. Is there anyway I can get the machines to grab a dhcp address much earlier? Maybe initialize the network card to acquire an address from DHCP server before windows starts to load? Maybe a bios change or something? Would like to do this for both LAN and Wireless cards if possible.

Most machines are running windows 7

Thanks
SJMP
0
Comment
Question by:sparkis
  • 8
  • 5
  • 2
  • +4
20 Comments
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35084115
What is the duration of the lease?
Usually they only renew once a week or so.
If you lengthen the lease time they will not need to re aquire with every boot?
0
 

Author Comment

by:sparkis
ID: 35084129
Sorry not a lease issue. More about getting the network card(s) initialized sooner. After login the Network Card is (spinning and the network connections are being setup). I want to get this done quicker/faster. Speed up the whole boot process.
0
 
LVL 8

Expert Comment

by:MarkieS
ID: 35084157
You can set a group or local policy setting -

Computer Configuration\Administrative Templates\System\Logon

Always Wait for Network
0
 
LVL 1

Expert Comment

by:edwalters
ID: 35084172
Doesn't sound like a network card issue or a DHCP issue.  How long does it take for a user to be logged on from starting the machine?  Are you in an Active Directory domain?
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35084174
You stated " the network card is circling acquiring a dhcp address after logon"

It only does that if it needs to aquire a new lease.
0
 
LVL 8

Expert Comment

by:MarkieS
ID: 35084266
You can set a group or local policy setting -

Computer Configuration\Administrative Templates\System\Logon

"Always Wait for Network at Computer Startup and Logon"

Determines whether Windows waits for the network during computer startup and user logon. By default, Windows does not wait for the network to be fully initialized at startup and logon. Existing users are logged on using cached credentials, which results in shorter logon times. Group Policy is applied in the background once the network becomes available.
0
 
LVL 3

Expert Comment

by:jetpowercom
ID: 35084275
Two ways come to mind for manually assigning IPs to the machines:

1) On each machine, in  Local Area Connection>Properties>Internet Protocol(TCP/IP)>Properties, you can assign the various properties (IP address, subnet mask, default gateway, DNS server address).  The path here applies to an XP machine; Windows 7 will be similar.  

2) In DHCP, you can assign an address to each machine by its network card's MAC address.  

Both ways involve knowing the assignable range of IPs; the second way involves access to DHCP on the server.

Hope this helps!
0
 

Author Comment

by:sparkis
ID: 35086292
Sorry guys, I was not clear. This has nothing to do with setting up DHCP or assigning static IPs.
I want the network card to initialize sooner, it looks like it does not finish initializing until during/after login. I want it to initialize earlier, maybe I can change this in the bios or something?

0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 35086808
I've seen this before - notably more with laptops than desktops.
The last time I saw it there was a problem with the BIOS.  There was no workaround.

You should be able to verify this by installing a different OS on one of the affected machines and testing again - if the same issue persists its a hardware problem.
0
 
LVL 8

Expert Comment

by:MarkieS
ID: 35093237
Sorry to repeat post but this sounds like your exact request but you've made no comment on it!

You can set a group or local policy setting -

Computer Configuration\Administrative Templates\System\Logon

"Always Wait for Network at Computer Startup and Logon"

Determines whether Windows waits for the network during computer startup and user logon. By default, Windows does not wait for the network to be fully initialized at startup and logon. Existing users are logged on using cached credentials, which results in shorter logon times. Group Policy is applied in the background once the network becomes available.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:sparkis
ID: 35094382
Yes it was disabled/not configured.

I noticed that even on servers with Static IP/s I see the network icon spinning with the globe after logon.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 35094453
If the network location has not been set the Icon will display the spinning circle.
Also, if you are behind a firewall and do not have direct or proxied internet access you will probably see this.
0
 
LVL 8

Expert Comment

by:MarkieS
ID: 35094759
What happens if you enable it and apply the policy?
0
 

Author Comment

by:sparkis
ID: 35094797
It was originally enabled. I then disabled it when I read your original post. Waited for replication, gpupdate/force and tried. Really made no difference.
0
 

Author Comment

by:sparkis
ID: 35148381
I think I do see an issue with DHCP and Windows 7 Clients. It appears that they are trying to obtain a new DHCP leaser every time the machine is rebooted. I just confirmed this on a few clients.

Logon - obtains new DHCP address. Shows that lease is set for the next 8 days, which is the correct lease duration for our DHCP server.
Then reboot the client, and logon, it obtains the dhcp address again. It is usually the same IP address - I do not see multiple leases issues to the same machine on the dhcp server. Yet every time you restart it will obtain an address again.

Any ideas? The DHCP server looks ok.
0
 

Accepted Solution

by:
sparkis earned 0 total points
ID: 35284101
this issue was switch related and was resolved by reconfiguring how the firewall, lan and server are communicating.
0
 
LVL 8

Expert Comment

by:MarkieS
ID: 35287074
Just nice to see you got it sorted...

all the best

Markies
0
 

Author Comment

by:sparkis
ID: 35287986
Thanks Mark. Appreciate the suggestions nonetheless.
0
 

Author Closing Comment

by:sparkis
ID: 35321781
it was strictly hardware issue. my bad. if you want the points just yell and I will give them to ya.
0
 

Expert Comment

by:ESPNS
ID: 38300422
Can you please share what settings where changed on your switches and or Firewall?
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This article is in response to a question (http://www.experts-exchange.com/Networking/Network_Management/Network_Analysis/Q_28230497.html) here at Experts Exchange. The Original Poster (OP) requires a utility that will accept a list of IP addresses …
Transparency shows that a company is the kind of business that it wants people to think it is.
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now