Php wont display errors

I have ubuntu server 10.10 running apache2.
phpinfo() states that display_errors is off.

in my php.ini (development) file - i have it set on
'E_ALL | E_STRICT' &
display_errors = 'on'

Yet, I made a page with intentional errors that aren't showing up.
LVL 1
ImaginxAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

WhiteSeedCommented:
try In .htaccess:
display_errors = 1
php_value error_reporting 2147483647
0
ImaginxAuthor Commented:
there is no /htaccess file in any of the www directories
0
WhiteSeedCommented:
you must create an .htacces file in the directory where you want apply the effect. The effect will be applicated in all sub-directory

here you can found a good documentation of the .htaccess file
http://httpd.apache.org/docs/2.2/howto/htaccess.html
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

ImaginxAuthor Commented:
WhiteSeed, can you explain this to me ::

"You should avoid using .htaccess files completely if you have access to httpd main server config file."

This is right in the beginning of that link you sent me to....

If I have access to the httpd.conf file - should I look into that first ??
0
WhiteSeedCommented:
htacces are for the users that can't edit the httpd file if you have access to this file i think that with the same code you can do it:
<Directory "<...>/html/beta/usercomponent">
php_value error_reporting 2147483647
 </Directory>
0
ImaginxAuthor Commented:
Ok, so I'm going to add this block into the httpd.conf ..

<Directory "/var/www">
php_value error_reporting 2147483647
 </Directory>
0
WhiteSeedCommented:
if you have problem add to display_errors = 1
0
ImaginxAuthor Commented:
Whiteseed, I haven't been back to that office to play with the server - I will post what I find when I'm back there. Sorry to not have been able to test it sooner.
0
ImaginxAuthor Commented:
reinstalled the php5 module into linux ... (left setting default on reinstall)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ImaginxAuthor Commented:
reinstall module displayed errors
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.