Solved

Cisco Switch can't ping anything

Posted on 2011-03-09
27
2,456 Views
Last Modified: 2012-05-11
I configured this Cisco 2950 switch. It's in production. I have our servers connected to the switch. I can the servers with no problems.

However, I can not ping the switch (192.168.1.101) itself. I can't telnet into the switch. I have to hyperterm into it.

When I do hyperterm into the switch, I can not ping anything from the switch.

How can I make this switch pingable? How can I telnet into this switch?
Any help would be appreciated.
Thanks

EQUIPMENT:
Model number: WS-C2950-24
C2950 Software (C2950-I6Q4L2-M), Version 12.1(9)EA1
sh run
Building configuration...

Current configuration : 1977 bytes
!
! Last configuration change at 08:45:02 EST Wed Mar 9 2011
! NVRAM config last updated at 16:04:12 EST Tue Mar 8 2011
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco2950
!
enable secret 5 $1$0x999X$XXX.XXXXXXXXXXXXX
enable password expertexchange
!
clock timezone EST -5
ip subnet-zero
!
spanning-tree portfast default
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 switchport mode access
 no ip address
!
interface FastEthernet0/2
 no ip address
!
interface FastEthernet0/3
 no ip address
!
interface FastEthernet0/4
 no ip address
!
interface FastEthernet0/5
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/6
 no ip address
!
interface FastEthernet0/7
no ip address
!
interface FastEthernet0/8
 no ip address
!
interface FastEthernet0/9
 no ip address
!
interface FastEthernet0/10
 no ip address
!
interface FastEthernet0/11
 no ip address
!
interface FastEthernet0/12
 no ip address
!
interface FastEthernet0/13
 no ip address
!
interface FastEthernet0/14
 no ip address
!
interface FastEthernet0/15
 no ip address
!
interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 no ip address
!
interface FastEthernet0/18
 no ip address
!
interface FastEthernet0/19
 no ip address
!
interface FastEthernet0/20
 no ip address
!
interface FastEthernet0/21
 no ip address
!
interface FastEthernet0/22
 no ip address
!
interface FastEthernet0/23
 switchport mode trunk
 no ip address
!
interface FastEthernet0/24
 switchport mode trunk
 no ip address
!
interface Vlan1
 ip address 192.168.1.101 255.255.255.0
 no ip route-cache
!
interface Vlan10
 ip address 10.0.1.10 255.255.255.0
 no ip route-cache
 shutdown
!
ip default-gateway 192.168.1.10
ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 exec-timeout 60 0
 password 7 0346790FFFFB234F68
 login
line vty 5 15
 password 7 0346790FFFFB234F68
 login
!
end

Cisco2950#

Open in new window

0
Comment
Question by:greatbay
  • 13
  • 7
  • 3
  • +3
27 Comments
 
LVL 34

Expert Comment

by:Istvan Kalmar
Comment Utility
Hi,

the config seems to good.,... you able to ping all address on 192.168.1.0/24 subnet!

Best regards,
Istvan
0
 
LVL 8

Expert Comment

by:hunart
Comment Utility
There might be an ICMP restrict on your router so please check the access list on router and make sure that the router allows this.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
Comment Utility
Please show us:

sh vlan
sh ip int brief
0
 
LVL 17

Expert Comment

by:MAG03
Comment Utility
Where are the client machines located? Does the router with ip 192.168.1.10 have routes to the 10.0.1.0 network?
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
From the Switch, I can't ping anything, except itself (192.168.1.101). I can't even ping the default gateway.

I'm not using any access-list on any of our routers.

I also tried changing the switch IP from 101 to 132. Nothing.
0
 
LVL 1

Expert Comment

by:DColclazier
Comment Utility
Any chance you're having an IP conflict? Seems odd to IP a switch that high in the range...
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23
2    VLAN0002                         active    
10   VLAN0010                         active    
11   Voice-Largo                      active    
104  Guest-Network                    active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0  
2    enet  100002     1500  -      -      -        -    -        0      0  
10   enet  100010     1500  -      -      -        -    -        0      0  
11   enet  100011     1500  -      -      -        -    -        0      0  
104  enet  100104     1500  -      -      -        -    -        0      0  
1002 fddi  101002     1500  -      -      -        -    -        0      0  
1003 tr    101003     1500  -      -      -        -    -        0      0  
1004 fdnet 101004     1500  -      -      -        ieee -        0      0  
1005 trnet 101005     1500  -      -      -        ibm  -        0      0  

Cisco2950#sh int ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Vlan1                      192.168.1.101   YES manual up                    up      
Vlan10                     10.0.1.10       YES NVRAM  administratively down down    
FastEthernet0/1            unassigned      YES unset  up                    up      
FastEthernet0/2            unassigned      YES unset  up                    up      
FastEthernet0/3            unassigned      YES unset  up                    up      
FastEthernet0/4            unassigned      YES unset  up                    up      
FastEthernet0/5            unassigned      YES unset  up                    up      
FastEthernet0/6            unassigned      YES unset  up                    up      
FastEthernet0/7            unassigned      YES unset  up                    up      
FastEthernet0/8            unassigned      YES unset  up                    up      
FastEthernet0/9            unassigned      YES unset  up                    up      
FastEthernet0/10           unassigned      YES unset  up                    up      
FastEthernet0/11           unassigned      YES unset  up                    up      
FastEthernet0/12           unassigned      YES unset  up                    up      
FastEthernet0/13           unassigned      YES unset  up                    up      
FastEthernet0/14           unassigned      YES unset  down                  down    
FastEthernet0/15           unassigned      YES unset  up                    up      
FastEthernet0/16           unassigned      YES unset  up                    up      
FastEthernet0/17           unassigned      YES unset  up                    up      
FastEthernet0/18           unassigned      YES unset  up                    up      
FastEthernet0/19           unassigned      YES unset  up                    up      
FastEthernet0/20           unassigned      YES unset  down                  down    
FastEthernet0/21           unassigned      YES unset  down                  down    
FastEthernet0/22           unassigned      YES unset  up                    up      
FastEthernet0/23           unassigned      YES unset  down                  down    
FastEthernet0/24           unassigned      YES unset  up                    up      

Cisco2950#sh int trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa0/24    on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/24    1-4094

Port      Vlans allowed and active in management domain
Fa0/24    1-2,10-11,104

Port      Vlans in spanning tree forwarding state and not pruned
Fa0/24    1-2,10-11,104
Cisco2950#
0
 
LVL 8

Expert Comment

by:hunart
Comment Utility
You must have a firewall somewhere between your switch and the next hop.  Check the firewall for ICMP restrictions.

Can you trace the traffic and see where the traffic stops?
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
I have (3) cisco 2900 series switches. The other two switches are fine.
Cisco 2950 (192.168.1.239)
Cisco 2900 (192.168.1.93)
No problems with these switches.

Cisco 2950 (192.168.1.101). I can't telnet into this switch.
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
I checked the firewall, no ping restrictions.
0
 
LVL 8

Expert Comment

by:hunart
Comment Utility
Have you turned on the telnet session on the switch?

If not, please use this command:

>line vty 0 15
>password whateveryouchose
>login yourchoice

0
 
LVL 34

Expert Comment

by:Istvan Kalmar
Comment Utility
please show us:

sh line
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
I did the following:
TELNET SETUP
config t
line vty 0 4
exec-timeout 60 0
login
password cisco

It didn't work. I still can not telnet in to the switch, let alone ping this switch.


0
Network it in WD Red

There's an industry-leading WD Red drive for every compatible NAS system to help fulfill your data storage needs. With drives up to 8TB, WD Red offers a wide array of solutions for customers looking to build the biggest, best-performing NAS storage solution.  

 
LVL 1

Author Comment

by:greatbay
Comment Utility
Cisco2950#sh line
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
*    0 CTY              -    -      -    -    -      0       0     0/0       -
     1 VTY              -    -      -    -    -      3       0     0/0       -
     2 VTY              -    -      -    -    -      0       0     0/0       -
     3 VTY              -    -      -    -    -      0       0     0/0       -
     4 VTY              -    -      -    -    -      0       0     0/0       -
     5 VTY              -    -      -    -    -      0       0     0/0       -
     6 VTY              -    -      -    -    -      0       0     0/0       -
     7 VTY              -    -      -    -    -      0       0     0/0       -
     8 VTY              -    -      -    -    -      0       0     0/0       -
     9 VTY              -    -      -    -    -      0       0     0/0       -
    10 VTY              -    -      -    -    -      0       0     0/0       -
    11 VTY              -    -      -    -    -      0       0     0/0       -
    12 VTY              -    -      -    -    -      0       0     0/0       -
    13 VTY              -    -      -    -    -      0       0     0/0       -
    14 VTY              -    -      -    -    -      0       0     0/0       -
    15 VTY              -    -      -    -    -      0       0     0/0       -
    16 VTY              -    -      -    -    -      0       0     0/0       -

Cisco2950#
0
 
LVL 34

Accepted Solution

by:
Istvan Kalmar earned 125 total points
Comment Utility
it seems only the serial connection active!
Did you rebooted the swith?
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
I'll re-booted the switch at 5:00pm this evening.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
Comment Utility
ok
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
Just to let you know I don't have any serial connections on this switch. However, I'll re-booted the switch at 5:00pm this evening.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
Comment Utility
how can you reach the switch at this time?:)
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
I'm currently going through the console (hyper-terminal). Later on, I'm just going to power cycle the switch.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
Comment Utility
ok
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
Do you get anything from:

show cdp neighbours
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
Cisco2950#show cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cisco3550        Fas 0/24           159        R S I      Cisco WS-CFas 0/5
Cisco2950#

Cisco2950#ping 192.168.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.10, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Cisco2950#ping 192.168.1.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Cisco2950#
==--==
The Cisco3550 (192.168.1.6) is our core switch. The Cisco2950 (192.168.1.101) is plugged into port-5.
The Router (192.168.1.10) is our main router.
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
ok what about:

show ip arp

on the 2950?
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
Cisco2950#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.1.101           -   000a.f43e.5dc0  ARPA   Vlan1
Cisco2950#
==--=====--==
That's it.
0
 
LVL 1

Author Comment

by:greatbay
Comment Utility
IT WORKING!!!!

a cold re-boot fixed it.

I unplugged the switch for a second, then plugged it back in. It came back up in 20 seconds. I'm able to ping the Cisco2950 switch (192.168.1.101).

Sometime in the future, I'm gong to upgrade the firmware
==--=====--==
Cisco2950#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(9)EA1, RELEASE SOFTWARE (
fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Wed 24-Apr-02 06:57 by antonino
Image text-base: 0x80010000, data-base: 0x804E8000

ROM: Bootstrap program is CALHOUN boot loader

Cisco2950 uptime is 7 minutes
System returned to ROM by power-on
System image file is "flash:/c2950-i6q4l2-mz.121-9.EA1.bin"

cisco WS-C2950-24 (RC32300) processor (revision F0) with 20815K bytes of memory.

Processor board ID FHK0636W1CR
Last reset from system-reset
Running Standard Image
24 FastEthernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:0A:F4:3E:5D:C0
Motherboard assembly number: 73-5781-11
Power supply part number: 34-0965-01
Motherboard serial number: FOC06360DKM
Power supply serial number: PHI0631091J
Model revision number: F0
Motherboard revision number: A0
Model number: WS-C2950-24
System serial number: FHK0636W1CR
Configuration register is 0xF

Cisco2950#
==--=====--==
Up grade to Version 12.1(22)EA1

Anyways, thanks for all your help.

0
 
LVL 1

Author Closing Comment

by:greatbay
Comment Utility
A simple re-boot of the switch was needed. That's it.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now