Solved

Exchange 2003 -> Exchange 2010

Posted on 2011-03-09
11
3,891 Views
Last Modified: 2013-08-11
Hello I am running exchange 2003 and in the process of migrating to exchange 2010. I did all the prep successfully and another tech installed the exchange 2010 on a VM windows 2008 x64 R2  platform.
I am attempting to configure the exchange 2010 using the CBT Nuggets but running into some problems.
Under Organization Configuration - > Hub Transport properties -> e-mail Address Policies I get this warning
Recipient policy object that don't contain e-mail address won't be shown unless you include the includeMailboxSettingOnlyPolicy parameter in the Get-EmailAddressPolicy cmdlet

I did apply the policy however if I try to edit the policy, I get

The specified e-mail address policy couldn't be edited. E-mail address policies with legacy versions of Exchange must be upgraded using the "Set-EmailAddressPolicy task with the Exchange 2010 filter specified





0
Comment
Question by:FalconTwo
  • 5
  • 5
11 Comments
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35085610
You need to upgrade the policies, run the following command from the Exchange Management Shell:

Get-EmailAddressPolicy | where {$_.RecipientFilterType –eq “Legacy”} | Set-EmailAddressPolicy –IncludedRecipients AllRecipients
0
 

Author Comment

by:FalconTwo
ID: 35085885
This is what I get
[PS] C:\Windows\system32>The term 'Get-EmailAddressPolicy' is not recognized as the name of a cmdlet, function, script f
ile, or operable program
The term 'The' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spellin
g of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:4
+ The <<<<  term 'Get-EmailAddressPolicy' is not recognized as the name of a cmdlet, function, script file, or operable
 program
    + CategoryInfo          : ObjectNotFound: (The:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

[PS] C:\Windows\system32>. Check the spelling of the name, or if a path was included, verify that the path is correct an
d try again.
The term 'Check' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spell
ing of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:2
+ . <<<<  Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
    + CategoryInfo          : ObjectNotFound: (Check:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

[PS] C:\Windows\system32>At line:1 char:23
Invalid command.

The AT command schedules commands and programs to run on a computer at
a specified time and date. The Schedule service must be running to use
the AT command.

AT [\\computername] [ [id] [/DELETE] | /DELETE [/YES]]
AT [\\computername] time [/INTERACTIVE]
    [ /EVERY:date[,...] | /NEXT:date[,...]] "command"

\\computername     Specifies a remote computer. Commands are scheduled on the
                   local computer if this parameter is omitted.
id                 Is an identification number assigned to a scheduled
                   command.
/delete            Cancels a scheduled command. If id is omitted, all the
                   scheduled commands on the computer are canceled.
/yes               Used with cancel all jobs command when no further
                   confirmation is desired.
time               Specifies the time when command is to run.
/interactive       Allows the job to interact with the desktop of the user
                   who is logged on at the time the job runs.
/every:date[,...]  Runs the command on each specified day(s) of the week or
                   month. If date is omitted, the current day of the month
                   is assumed.
/next:date[,...]   Runs the specified command on the next occurrence of the
                   day (for example, next Thursday).  If date is omitted, the
                   current day of the month is assumed.
"command"          Is the Windows NT command, or batch program to be run.

[PS] C:\Windows\system32>+ Get-EmailAddressPolicy <<<<  | where {$_.RecipientFilterType -eq "Legacy"} | Set-EmailAddress
Policy -IncludedRecipien
Missing expression after unary operator '+'.
At line:1 char:2
+ + <<<<  Get-EmailAddressPolicy <<<<  | where {$_.RecipientFilterType -eq "Legacy"} | Set-EmailAddressPolicy -Included
Recipien
    + CategoryInfo          : ParserError: (+:String) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : MissingExpressionAfterOperator

[PS] C:\Windows\system32>ts AllRecipients
The term 'ts' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling
 of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:3
+ ts <<<<  AllRecipients
    + CategoryInfo          : ObjectNotFound: (ts:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

[PS] C:\Windows\system32>    + CategoryInfo          : ObjectNotFound: (Get-EmailAddressPolicy:String) [], CommandNotFou
ndException
Missing expression after unary operator '+'.
At line:1 char:6
+     + <<<<  CategoryInfo          : ObjectNotFound: (Get-EmailAddressPolicy:String) [], CommandNotFoundException
    + CategoryInfo          : ParserError: (+:String) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : MissingExpressionAfterOperator

[PS] C:\Windows\system32>    + FullyQualifiedErrorId : CommandNotFoundException

0
 

Author Comment

by:FalconTwo
ID: 35085921
Did you mean
Set-EmailAddressPolicy | where {$_.RecipientFilterType –eq “Legacy”} | Set-EmailAddressPolicy –IncludedRecipients AllRecipients instead og Get-EmailAddresspolicy. I change the GET to Set-EmailAddress etc.. It then asked for the identity
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35085950
No, it should be Get.

Try this:


Set-EmailAddressPolicy "Default Policy" -IncludedRecipients AllRecipients

Replace the Default Policy with the name of the address policy you are trying to edit
0
 

Author Comment

by:FalconTwo
ID: 35086118
OK This is what I get this time. Remember I still have the exchange 2003 in my Org

[PS] C:\Windows\system32>Set-EmailAddressPolicy "Default Policy" -IncludedRecipients AllRecipients

Confirm
To save changes on object "Default Policy", the object must be upgraded to the current Exchange version. After the
upgrade, this object cannot be managed by an earlier version of Exchange Management Tools. Do you want to continue to
upgrade and save the object?
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [?] Help (default is "Y"):
[PS] C:\Windows\system32>
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 74

Expert Comment

by:Glen Knight
ID: 35086170
Say yes.

It doesn't matter about the 2003 server.

The org config will now be controlled by 2010
0
 

Author Comment

by:FalconTwo
ID: 35086775
[PS] C:\Windows\system32>Set-EmailAddressPolicy "Default Policy" -IncludedRecipients AllRecipients
The operation can't be performed on the default e-mail address policy.
    + CategoryInfo          : InvalidOperation: (Default Policy:ADObjectId) [Set-EmailAddressPolicy], InvalidOperation
   Exception
    + FullyQualifiedErrorId : 782AD023,Microsoft.Exchange.Management.SystemConfigurationTasks.SetEmailAddressPolicy

[PS] C:\Windows\system32>
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35087035
Do you have any mailbox management policies set on the address list in Exchange 2003?
0
 

Author Comment

by:FalconTwo
ID: 35087099
No I just check, if there's its all default
0
 
LVL 74

Accepted Solution

by:
Glen Knight earned 500 total points
ID: 35087167
OK, there's no reason why that shouldn't work.

Can you try:

Get-EmailAddressPolicy | where {$_.RecipientFilterType –eq “Legacy”} |
Set-EmailAddressPolicy –IncludedRecipients AllRecipients

from: http://www.simple-talk.com/sysadmin/exchange/upgrade-exchange-2003-to-exchange-2010---part-ii/
0
 

Expert Comment

by:atoz110
ID: 39400943
What do you suggest in a case where there were mailbox management policies placed in Exchange 2003? I believe that is why I am getting this error. Also my 2003 server has been decommissioned. Any suggestions?

[PS] C:\Windows\system32>Set-EmailAddressPolicy "Default Policy" -IncludedRecipients AllRecipients
The operation can't be performed on the default e-mail address policy.
    + CategoryInfo          : InvalidOperation: (Default Policy:ADObjectId) [Set-EmailAddressPolicy], InvalidOperation
   Exception
    + FullyQualifiedErrorId : 72E0D31B,Microsoft.Exchange.Management.SystemConfigurationTasks.SetEmailAddressPolicy
0

Featured Post

Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This video discusses moving either the default database or any database to a new volume.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now