Connecting to companyweb on SBS2008

I've set up SBS 2008 with a Sharepoint Site.  I can connect from computers on the domain using companyweb as the address, and I can connect offnetwork using the public domain for the site.  I have several computers on the local network that are not on the domain, in SBS 2003 I could connect to the internal website on these computers using the server's IP address or machine name.  But I can't do this in 2008  Anyone know what needs to be done to make this happen?

Who is Participating?
questlConnect With a Mentor Commented:
The secondary DNS is only used, when the primary dns is not available. You should use the SBS as primary dns, as it will forward the dns request to the isp dns.

You can check this by doing a nslookup

normally in SBS 2008 the companyweb is available through the Remote Work Space (rww), which is in
the standard config made available through the internet assistant. You have also to open a DMZ Port to your SBS 2008 Server (Port 987) and you should be able to access it from the Internet.

jpinchAuthor Commented:
I can connect from the internet, and from the domain.  I don't want the local computers not on the domain to have to connect via the internet.  I was able to do this in SBS 2003
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

Did you try the full quallified domain name (e.g. http://companyweb.domain.loca)? Do you have as primary DNS your SBS server in the workstation configuration)?

Do you get an authentication window?
jpinchAuthor Commented:
I'm currently in test mode-I have the server and workstation on a dummy network with no internet connection.  I added the IP of the server as secondary DNS (Primary is from the ISP) and was able to connect!  But will this interfere with Internet DNS once I go live?
Cliff GaliherCommented:
SBS 2008 moved a few things around and tweaked how host headers work which is why the functionality changed. Because of the host header, you have two choices to resolve your issue:

1) Add a "companyweb" entry to the hosts file of the machines in question
2) Change the DNS settings of the machines in question to use the SBS server for DNS (DNS is unauthenticated so this is perfectly acceptable)

In either case, the result will be that you can type "companyweb" in the browser window, the lookup will succeed, and the browser will connect to the server *and* send the appropriate host header for IIS to deliver the sharepoint site.


jpinchAuthor Commented:
Thanks to all, I added the server's IP to DNS on the clients, and all is working well.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.