Shadow Copies not growing to use maximum space

I have a 2003 SP2 server that has been in production for quite some time, running smoothly - but recently I've been having a issue with a shadow copy protected volume.

The volume is setup to capture two shadow copies - 7am and 12pm every day. The storage area is set to a maximum of 27877MB (27.224GB).  In the past this worked fine.

The problem I'm having is that the Shadow Copies are not growing to use all of the 'Maximum Shadow Copy Storage space'. The 'Used Shadow Copy Storage space' is at 10.962GB - I've seen it go a bit higher, but never over 12GB. As a result, I'm not capturing as many prior versions of the volume as I would like.  

There are no errors in the System log.  Running 'vssadmin list shadowstorage' confirms that max size is 27GB.  Running 'vssadmin list writers' shows all states as 'stable' and no errors.  Running 'vssadmin list providers' shows there is only one provider (Microsoft Software Shadow Copy Provider, version 1.0.0.7).

The only change that occurred was this server was recently setup to also use DPM 2010.  DPM captures the same volume, but at 2am. This issue started occurring *after* DPM 2010 was set to protect this server.  (DPM 2010 is working according to expectation.)

I'd appreciate any ideas about how to narrow down why the 'Maximum Size' setting is seemingly being ignored.  Fixing this would double the number of shadow copies I have for this volume.

Thanks.





bllarsonAsked:
Who is Participating?
 
bllarsonConnect With a Mentor Author Commented:
I yanked out out DPM 2010 from protecting the server that was having the issue with Shadow Copies - as soon as I did that, the local shadow copy service started behaving according to expectation.  I'm certain that the local shadow copy service was impacted by having DPM 2010 also doing its thing - but I can't say that I understand the mechanics behind why.

In general it's my sense that if you deploy DPM 2010, then you *should not* also be doing local shadow copies.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
You can have a MAXIMUM of 64 snapshots (I've never been able to nail down if that's 64 snapshots of each file or 64 snapshots of the entire volume; I THINK volume).  So if the 64 snapshots don't approach 27 GB, then you'll never use 27 GB.
0
 
bllarsonAuthor Commented:
That's interesting and good to know... but either way, I'm not at 64 snapshots.  

I only have 7 snapshots going back five days (7am & 12pm) on the server itself.

The protection group in DPM 2010 is set for a seven day retention range, but only once per day (2am) - so that's only another 7 snapshots.

I'm only at 14 snapshots total....  (I wonder if there's any correlation ?)
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Not intimately familiar with DPM so I can't be sure...
0
 
bllarsonAuthor Commented:
For anyone that is interested...

I tried installing v3 of KB940349 middle of last week. (Volume Shadow Copy Service update roll-up).  No change to this issue.

I believe that the issue may have something to do with how the protection group is setup within DPM 2010.  There are two settings within DPM 2010 that are new to me (in relation to VSS; 'Retention Range' and 'Synchronization frequency'); and I suspect that setting them on DPM 2010 has impacted how the Shadow Copy Service on the local server behaves.  My hypothesis is that once you link DPM 2010 with a servers Shadow Copy Service; the settings from DPM 2010 become dominant, and impact how the local server Shadow Copy behaves, even if the shadow copy being created is not directly for a DPM 2010 backup.  I'm trying to test this idea now...

If anyone has any insight or ideas, I'd sure appreciate it.


0
 
Jackie ManCommented:
1. From Windows Explorer of the local volume which you create the snapshots, right-click the drive and select Properties.
2. Select the Shadow Copies tab.
3. Count how snapshots under Shadow copies of selected volume and check whether it exceeds 64 snapshots.

Source: http://www.windowsitpro.com/article/file-management/how-can-i-manually-trigger-windows-server-2003-to-take-a-volume-shadow-copy-service-vss-snapshot-
0
 
bllarsonAuthor Commented:
I solved it myself - or at least I was able to make the problem go away.

If anyone else deals with DPM 2010 and how it plays with the local Shadow Copy Service, they may find this useful.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.