Virtual machines automatically start back up

I do not have an HA cluster, and in Virtual Machine Startup/Shutdown alll the VMs are set to Manual Startup and Startup is set to Disabled. However, whenever I shutdown the machines, they automatically start back up. Where else could this be set?
CorinneSpearsAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Danny McDanielConnect With a Mentor Clinical Systems AnalystCommented:
The only other things I can think of are vApps and  WOL (wake on LAN).  there's an option in Edit Settings that allows you to turn WOL on or off and it should be obvious if it's part of a vApp group.
0
 
bgoeringCommented:
What OS is in your VM? How are you powering down the VM? ACPI needs to be enabled in order for the guest to actually power down the VM from the shutdown. I think that there are GPO policy settings to disable shutdown and make it work like a restart - could that be what is happening?

If you select power off from vmware does it stay powered down?
0
 
CorinneSpearsAuthor Commented:
It's happening with Windows 2008 server, 2003 R2 server, and windows XP. I've tried shutting down from within Windows, Shutdown Guest within VMware, and Power Off. The gurst automatically starts up each time.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Danny McDanielClinical Systems AnalystCommented:
within the client, do you see any tasks in the lower pane?  that might give a clue as to what is powering the VM back on.  Also, check events/tasks tab to get info about power on.
0
 
CorinneSpearsAuthor Commented:
Nothing in VMware. The reason I was trying to shutdown the machine is because I was removing it from inventory to move the files to another datastore. When I added the VM back to inventory, it immediately started itself up. I'm at a loss where else to look on the ESX host.
0
 
Danny McDanielClinical Systems AnalystCommented:
If you create a new, blank VM with no OS on that host, does it power on automatically, too?
0
 
IanThCommented:
its in the advanced setting

 vm auto start and stop
0
 
CorinneSpearsAuthor Commented:
It does not happen with a new VM. It only happens with the Windows machines.
0
 
bgoeringCommented:
Is it possible that you have a monitoring system in place that notices the machine isn't there and tries to restart it? There are a couple of interfaces (vSphere RCLI, PowerCLI) that can be used to remotely start a virtual machine.
0
 
CorinneSpearsAuthor Commented:
We use Host Monitor. It does not restart the servers. I think it's either something in VMware or Windows XP.
0
 
bgoeringCommented:
If you actually succeed in powering the vm off in the vSphere client (right click on the vm, select power then power off) and it still comes back up that would pretty much rule out XP. These would leave either something in VMware or some external process causing it to power back on.

I am not aware of (but don't know everything!) any setting that might cause the behavior you describe. I do know some vApp features allow you to power up and down groups of machines. Is the vm in question part of a vApp?

As danm66 mentioned earlier please watch the "Recent Tasks" pane at the bottom of the vSphere client for any activity. You should see power off messages when you go to power it down. If it immediately comes back with initiated power on and/or powering on messages see who it was initiated by and post that info back here.

The only other possibility that occurs to me is that some external process is using API or webservice calls to power the vm back on.

0
 
Danny McDanielClinical Systems AnalystCommented:
I would think that you would see login messages in the vpxd log as the external process powers on the VM and possibly some log entries for the requested action.
0
 
CorinneSpearsAuthor Commented:
Here's the settings in Vmware.
 VMware settingsEven though start up is set to Disabled, the VM's start even if I Power Off the machines. I was able to complete what I needed to by powering off the machine and then immediately removing from inventory. After adding it back to inventory and starting up the VM again, I tried shutting down the VM in Windows. It shuts down and then starts back up again.
0
 
bgoeringCommented:
You might want to take a look at these articles:

For ESX: http://kb.vmware.com/kb/1004340
For ESXi: http://kb.vmware.com/kb/1014165

Good Luck
0
 
CorinneSpearsAuthor Commented:
WOL, that's it. It's set for the NIC. Now, I just need to figure out how to turn it off. The options are greyed out.
0
 
Danny McDanielClinical Systems AnalystCommented:
You have to power down the VM to un-check the option.
0
 
Squidly_ManCommented:
The other thing to keep in mind is, when using VMware View, settings within the VDI Pool can ensure Windows Desktop VMs are always powered on.  This is a functionality of VMware View and will be configured within the View Desktop Pool Settings to ensure desktops within the pool are always powered on.
View Desktop Pool Settings - Ensure Desktops are always powered on
0
All Courses

From novice to tech pro — start learning today.