Solved

SQL server ent 2000 AWE setup win2003 ent 32bit

Posted on 2011-03-09
10
609 Views
Last Modified: 2012-06-21
Hello all,
We are having troubles getting the SQL 2000 to address more memory.

The 2 environments are both win2003 enterprise 32 bit running sql 2000 enterprise (both have sp4, one has the post sp4 hotpatches).

OS has 12 gb and /PAE and /3GB are set. And there is ample memory available for SQL at start up time.

SQL config settings:
min server memory (MB) = 3084
max server memory (MB) = 3084 (would like to bump this up in both cases).
set working set size = 0 (required by vendor)
awe enabled = 1

The service account is running with the "Lock Page in Memory" permission.
And there is ample memory.
Systems have been restarted multiple times.

But we always get the error
"Warning: unable to allocate 'min server memory' of 3084MB."
And SQL server appears to dynamically allocate memory up to about 2.7GB.

The sql error log never reads "Address Windowing Extension enabled"
Nor is there an error telling us it cannot use extended memory.

I am clearly missing a step here, but not sure what.
Any ideas?

Thanks for your help.

(The good news is the business finally decided to go to a current 64 bit environment, the bad is that is it is not for another 6 months).
0
Comment
Question by:catlantis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
10 Comments
 

Author Comment

by:catlantis
ID: 35088468
Hi Daniel.

I did apply this to one of the servers in question.

Also I applied
http://support.microsoft.com/kb/916287
"A cumulative hotfix package is available for SQL Server 2000 Service Pack 4 build 2187"

Maybe one over wrote the other? I will see if I can appy 899761 again

thanks
0
 

Author Comment

by:catlantis
ID: 35089017
Yup, re-tried the patch from KB899761

Still doing the same thing, not allocating.

Although I am not asking for more than 1/2 the available memory, so the kb should not apply.



0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 14

Expert Comment

by:Daniel_PL
ID: 35092087
Can you double check that your operating system can see all RAM?
By running following quey in cmd you can chceck whether /3GB is working:
 
wmic /node:<server_name> OS get MaxProcessMemorySize

Open in new window

It should be higher than 2097024 (KB).

Run following and confirm that you have set awe enabled and did not set Set working set size option.
sp_configure 'show advanced options', 1
RECONFIGURE
GO
sp_configure
GO
sp_configure 'show advanced options', 0
RECONFIGURE
GO

Open in new window

Please also check whether you have set startup parameters, especially -g.
0
 

Author Comment

by:catlantis
ID: 35096611
HI Daniel,

Thanks for your message.

The value I get for my test box is: 3145600

The sql values are :
awe enabled      0      1      1      1
set working set size      0      1      0      0

So awe set, and set working size is not. (last value column is run_value)

We are not running any start up parameters other than the standard ones for the master db and error logs.

I am not sure about setting a parameter on our prd box
We are running SAP on top of this. And they say:
"SAP does not require or generally recommend to modify any SQL Server startup parameter."

I will certainly try the option in our QAS box. If that works, will get confirmation from SAP on setting it on PRD (although they have been extremely unhelpful on this topic :) )

Thanks!
Chris




0
 
LVL 14

Expert Comment

by:Daniel_PL
ID: 35098878
Don't set set working set and startup options. I wanted you to confirm it is turned off.
Please verify options with this guide on options:
http://www.sql-server-performance.com/sql_server_performance_audit5.asp
0
 

Author Comment

by:catlantis
ID: 35099206
I have not modified anything yet. (But I do have a qa box to tinker with if needed).

We have the settings as indicated set for years.
Settings determined by max memory size speced by SAP:

"min server memory (MB)" = "max server memory (MB)" = 3084
"set working set size" = 0
"awe enabled" = 1

Deviations from default installation as directed by SAP:
  "network packet size" = 8192
  "priority boost" = 0
  "max degree of parallelism" = 1 (recommends setting this dynamically on when aggregates occur, off when oltp users come online)
  "max worker threads" = 255

Kept as default as recommended by SAP:
  "affinity mask"                    =      0
  "c2 audit mode"                    =      0
  "cost threshold for parallelism"   =      5
  "cursor threshold"                =     -1
  "default full-text language"       =  1033
  "default language"                =      0
  "fill factor (%)"                  =      0
  "index create memory (KB)"        =      0
  "lightweight pooling"              =      0
  "locks"                            =      0
  "max text repl size (B)"           =  65536
  "media retention"                  =      0
  "min memory per query (KB)"        =   1024
  "nested triggers"                  =      1
  "open objects"                    =      0
  "query governor cost limit"        =      0
  "query wait (s)"                  =     -1
  "recovery interval (min)"          =      0
  "remote access"                    =      1
  "remote login timeout (s)"         =     20
  "remote proc trans"                =      0
  "remote query timeout (s)"         =    600
  "scan for startup procs"          =      0
  "two digit year cutoff"            =   2049
  "user connections"                =      0
  "user options"                    =      0


And also the boot.ini has /3GB and /PAE
0
 
LVL 14

Accepted Solution

by:
Daniel_PL earned 500 total points
ID: 35099377
I've got two sql servers 2000 running just fine with 10 GB of memmory. I'll check for you our settings, in addition did you try to set min server memory to 256MB or even to 1024MB just less than max. By using AWE max should be allocated once and not gave up. Try this approach.
0
 

Author Comment

by:catlantis
ID: 35121911
Hi Daniel,

Lowering the memory down on min server memory (MB) seems to work
I now see:
Address Windowing Extensions enabled.

in the error log.
I no longer see the "Warning: unable to allocate 'min server memory' of 3084MB" error.

And while sql has not yet allocated the amount, I will watch it today to see if it grows.

Thanks.

I reference the following for anybody here on the same SAP environment:
NW 640, sql server 2000 ent, win2003 ent (all 32 bit).
SAP note 327494 reads to set <mindb> = <maxdb> when setting awe enabled.
This appears incorrect.
Even SAP support recommends this setting directly as such, and it does not work.

Thanks, Daniel. I will set yours as the accepted solution shortly.

Chris
0
 
LVL 14

Expert Comment

by:Daniel_PL
ID: 35131807
I'm glad your problem is solved.

Take care,
Daniel
0

Featured Post

Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to reset the password of the sa account on a Microsoft SQL Server.  The steps in this article work in SQL 2005, 2008, 2008 R2, 2012, 2014 and 2016.
Slowly Changing Dimension Transformation component in data task flow is very useful for us to manage and control how data changes in SSIS.
Via a live example, show how to shrink a transaction log file down to a reasonable size.
Viewers will learn how to use the SELECT statement in SQL to return specific rows and columns, with various degrees of sorting and limits in place.

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question