Solved

Active Sync fails after Share Point 3.0 install

Posted on 2011-03-09
16
569 Views
Last Modified: 2012-05-11
Since installing Sharepoint 3.0 on an SBS2003 server, no phones work via Active Sync.  I have read articles on how to install Sharepoint 3.0 on an SBS2003 server which I followed, but it has stopped active sync working correctly.

Using https://www.testexchangeconnectivity.com i get Exchange ActiveSync returned an HTTP 500 response.

I have read articles saying that sharepoint uses NTML and I have turned default website back to Kerberos but still the 500 error.

I have reset the Virtual Directories in Exchange, but same error.  I'm 100% sharepoint caised the problem as it from that day, no phones have received any emails.

Any help please??

Thanks in advance
0
Comment
Question by:dcleaver
  • 7
  • 6
  • 2
  • +1
16 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35088206
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35088216
this is most likely caused by the .net version on the virtual directories being changed from 1.1 to 2.

Check all the virtual directories in IIS and make sure they are set to 1.1 and then do an IISRESET from the command prompt
0
 

Author Comment

by:dcleaver
ID: 35088307
I have found the link http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html in many different places (been working on this all day) and have gone through it exactly as it says, but no joy.

I have also checked the .net on the virtual directories and they are all 1.1.4322 although there is the choice of 2.0.5.0727 but 100& all 1.

thanks
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35088603
what is the port number on which the share pont is running

if its using the port 80 then defaulft website cant use that and we have this issue

if share point is using 80 make it to use 8080 and make Default website to use 80
0
 

Author Comment

by:dcleaver
ID: 35088692
I have the following in IIS

Default Web site port 80 and 443 bound to 192.168.0.2
A support site using port 80 but IP 192.168.0.3
Sharpoint using port 36372 on 192.168.0.2
Sharepoint Central Administration port 4625 on 192.168.0.2

The support site has be there since day one and never caused this issue

Thanks
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35088713
Please assign "All Unassigned" to your default website - not an IP Address, run iisreset and test again.
0
 

Author Comment

by:dcleaver
ID: 35088780
Hi Alanhardisty

I have tried what you suggested but still Exchange ActiveSync returned an HTTP 500 response.

Thank you for your help so far!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35088848
No problems - hopefully we will get there!!

Okay - are you using self-signed certificate or 3rd party?

Have you re-run the Connect to the Internet Wizard?  If not - please do and re-test.
0
 

Author Comment

by:dcleaver
ID: 35088930
we use a 3rd party certificate.

I have re run the connect to the internet wizard and now get a diferent error

A Web exception occurred because an HTTP 401 - Unauthorized response was received from Unknown.

I have had this earlier today it goes back to the 500 after restarting the server.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35088948
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35088963
what is the authentication on the Microsoft-server-ActiveSync VD

Please check whetehr u have Basic or not

if u dont have basic enable it and do a IISRESET
0
 

Author Comment

by:dcleaver
ID: 35089066
I have checked and changed a couple of settings and I now get this error.

An HTTP 403 forbidden response was received. The response appears to have come from Unknown. Body of the response: <body><h2>HTTP/1.1 403 Forbidden</h2></body>

My HTC phone now connects??

I have check form based authentication which is off as I tought that gave the error above?

0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35089082
Please enable FBA - it should be on by default on SBS 2003.

Do you have the exchange-oma virtual directory listed under the default website?
0
 

Author Comment

by:dcleaver
ID: 35089148
OK, I have enabled the FBA and reset IIS
With FBA enabled I get
An HTTP 403 forbidden response was received. The response appears to have come from Unknown. Body of the response: <body><h2>HTTP/1.1 403 Forbidden</h2></body>

Yes Exchnage-oma is under the default website

Phone still working?
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 35089189
You will see in the 403 error section that I have seen some phones still sync despite the 403 error!

If things are working (phones are syncing) - leave things as they are!
0
 

Author Closing Comment

by:dcleaver
ID: 35089213
alanhardisty, thank you for your help.  I have been working on this all day and although it still fails on the https://www.testexchangeconnectivity.com site, the phones seem to be working now.  Not sure what solved it, maybe running the internet connection wizard again, although I had done that earlier in the day.

Thank you so much!
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've often see, or have been asked, the question about the difference between the Exchange 2010 SP1 version, available as part of Small Business Server (SBS) 2011, and the “normal” Exchange 2010 SP1 Standard. The answer to the question is relativ…
SharePoint Designer 2010 has tools and commands to do everything that can be done with web parts in the browser, and then some – except uploading a web part straight into a page that is edited in SPD. So, can it be done? Scenario For a recent pr…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question