Solved

Active Sync fails after Share Point 3.0 install

Posted on 2011-03-09
16
566 Views
Last Modified: 2012-05-11
Since installing Sharepoint 3.0 on an SBS2003 server, no phones work via Active Sync.  I have read articles on how to install Sharepoint 3.0 on an SBS2003 server which I followed, but it has stopped active sync working correctly.

Using https://www.testexchangeconnectivity.com i get Exchange ActiveSync returned an HTTP 500 response.

I have read articles saying that sharepoint uses NTML and I have turned default website back to Kerberos but still the 500 error.

I have reset the Virtual Directories in Exchange, but same error.  I'm 100% sharepoint caised the problem as it from that day, no phones have received any emails.

Any help please??

Thanks in advance
0
Comment
Question by:dcleaver
  • 7
  • 6
  • 2
  • +1
16 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35088206
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35088216
this is most likely caused by the .net version on the virtual directories being changed from 1.1 to 2.

Check all the virtual directories in IIS and make sure they are set to 1.1 and then do an IISRESET from the command prompt
0
 

Author Comment

by:dcleaver
ID: 35088307
I have found the link http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html in many different places (been working on this all day) and have gone through it exactly as it says, but no joy.

I have also checked the .net on the virtual directories and they are all 1.1.4322 although there is the choice of 2.0.5.0727 but 100& all 1.

thanks
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35088603
what is the port number on which the share pont is running

if its using the port 80 then defaulft website cant use that and we have this issue

if share point is using 80 make it to use 8080 and make Default website to use 80
0
 

Author Comment

by:dcleaver
ID: 35088692
I have the following in IIS

Default Web site port 80 and 443 bound to 192.168.0.2
A support site using port 80 but IP 192.168.0.3
Sharpoint using port 36372 on 192.168.0.2
Sharepoint Central Administration port 4625 on 192.168.0.2

The support site has be there since day one and never caused this issue

Thanks
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35088713
Please assign "All Unassigned" to your default website - not an IP Address, run iisreset and test again.
0
 

Author Comment

by:dcleaver
ID: 35088780
Hi Alanhardisty

I have tried what you suggested but still Exchange ActiveSync returned an HTTP 500 response.

Thank you for your help so far!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35088848
No problems - hopefully we will get there!!

Okay - are you using self-signed certificate or 3rd party?

Have you re-run the Connect to the Internet Wizard?  If not - please do and re-test.
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:dcleaver
ID: 35088930
we use a 3rd party certificate.

I have re run the connect to the internet wizard and now get a diferent error

A Web exception occurred because an HTTP 401 - Unauthorized response was received from Unknown.

I have had this earlier today it goes back to the 500 after restarting the server.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35088948
0
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35088963
what is the authentication on the Microsoft-server-ActiveSync VD

Please check whetehr u have Basic or not

if u dont have basic enable it and do a IISRESET
0
 

Author Comment

by:dcleaver
ID: 35089066
I have checked and changed a couple of settings and I now get this error.

An HTTP 403 forbidden response was received. The response appears to have come from Unknown. Body of the response: <body><h2>HTTP/1.1 403 Forbidden</h2></body>

My HTC phone now connects??

I have check form based authentication which is off as I tought that gave the error above?

0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35089082
Please enable FBA - it should be on by default on SBS 2003.

Do you have the exchange-oma virtual directory listed under the default website?
0
 

Author Comment

by:dcleaver
ID: 35089148
OK, I have enabled the FBA and reset IIS
With FBA enabled I get
An HTTP 403 forbidden response was received. The response appears to have come from Unknown. Body of the response: <body><h2>HTTP/1.1 403 Forbidden</h2></body>

Yes Exchnage-oma is under the default website

Phone still working?
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 35089189
You will see in the 403 error section that I have seen some phones still sync despite the 403 error!

If things are working (phones are syncing) - leave things as they are!
0
 

Author Closing Comment

by:dcleaver
ID: 35089213
alanhardisty, thank you for your help.  I have been working on this all day and although it still fails on the https://www.testexchangeconnectivity.com site, the phones seem to be working now.  Not sure what solved it, maybe running the internet connection wizard again, although I had done that earlier in the day.

Thank you so much!
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

There is one common problem that all we SharePoint developers share: custom solution deployment. This topic can't be covered fully in this short article, so all I want to do in this one is to review it from a development-to-operations perspectiv…
Microsoft SharePoint Foundation 2010 and Microsoft SharePoint Server 2010 do not offer the option to configure the location of the SharePoint diagnostic trace log files during installation.  This can, however, be configured through Central Administr…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now