Why does PEAR DB give "DB Error: extension not found [DB Error: extension not found].."

I'm moving a small set of PHP/Postgres applications from Ubuntu 9.x to 10.10. When I try to run the application, I get this error:

DB Error: extension not found [DB Error: extension not found] ** pgsql://jean@/appx

The code is:

            require_once('DB.php');
            $db=DB::connect("pgsql://jean@/appx");
            if (PEAR::isError($db)) {
                      die($db->getMessage()."  ".$db->getUserInfo()." ");
            }
            if (DB::isError($db)){
                        die($db->getMessage());
            }

When I installed DB, I noticed that it's been supersceded by MDB2, what do I have to change to make it work with MDB2, or what do I need to do make the DB code work?

Thanks.

Jean
JPNeronAsked:
Who is Participating?
 
Julian MatzJoint ChairpersonCommented:
You're right.

I think I've figured it out though. First, you do actually need the package php5-pgsql. Secondly, you also need php5-mysql. Without MySQL support, PHP in Ubuntu won't support PgSQL either, apparently.

$ sudo aptitude install php5-pgsql php5-mysql

Now, if you want to use MDB2 instead of DB, it's fairly straight forward. Just do the following:

$ sudo pear install pear/MDB2

And then:

$ sudo pear install pear/MDB2#pgsql

Then you need to change your code to following:

            require_once('MDB2.php'); // CHANGE THIS LINE
            $db=MDB2::connect("pgsql://jean@/appx"); // CHANGE THIS LINE ALSO
            if (PEAR::isError($db)) {
                      die($db->getMessage()."  ".$db->getUserInfo()." ");
            }
            if (MDB2::isError($db)){ // AND THIS ONE
                        die($db->getMessage());
            }

Open in new window


Hope that fixes it for you.
0
 
Julian MatzJoint ChairpersonCommented:
Hi JPNeron,

See if the following works for you:

$ sudo aptitude install php5-psql

(Inside a terminal window, of course)
0
 
JPNeronAuthor Commented:
When I used 'php5-psql' as the package name, it said there was no such package. On a hunch, I tried 'php5-pgsql' instead, and it did download & install it, but I still get the error.
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
Julian MatzJoint ChairpersonCommented:
Sorry, it's more likely you're missing the Pear extension. My guess is that when you upgraded, the php extension directory probably changed. If this is the case, you'll need to reinstall the DB package. However, what I would do is try the MBD2 package first. If that fails, just re-install DB.

$ pear install MDB2

Make sure there are no errors, and take note of whether Pear has enabled the extension for you or not. You can post the last couple of lines from the output here.
0
 
JPNeronAuthor Commented:
Both those packages appear to be installed:

root@Ubuntu:/home/jean# pear install MDB2
pear/MDB2 is already installed and is the same as the released version 2.4.1
install failed
root@Ubuntu:/home/jean# pear install DB
pear/DB is already installed and is the same as the released version 1.7.13
install failed

If DB was missing, wouldn't I get an error on the require_once('DB.php') statement?

Also, just to clarify, I'm not upgrading a machine, I have a brand new machine and I copied the php pages from the old server to the new server.
0
 
JPNeronAuthor Commented:
We have progress!

Now I get:


MDB2 Error: connect failed _doConnect: [Error message: unable to establish a connection] ** pgsql(pgsql)://jean:xxx@/appx

Not sure what the problem is here. This user can run psql, access the 'appx' database, view tables, etc, etc. Maybe there's a problem in the postgres setup that prevents connections from apache?
0
 
Julian MatzJoint ChairpersonCommented:
Would you be able to temporarily switch back to DB? It seems to me that DB does error reporting more constructively than MDB2, by default anyway.

Perhaps there's a setting to make MDB2 spit out more details, but I'm not sure where to look for that. But if we can get it working with DB, we should then be able to get it working with MDB2 also.

I'm assuming you have PostgreSQL installed?

$ sudo aptitude install postgresql

0
 
JPNeronAuthor Commented:
Hooray! Just switching back to DB solved the problem, everything works as it should!

I guess the problem all along was I needed to install the php5-mysql package.

Thanks for the help!
0
 
JPNeronAuthor Commented:
The problem was the missing php5-mysql part of PEAR. After installing that, it was not necessary to change anything.
0
 
Julian MatzJoint ChairpersonCommented:
Good stuff! Glad I could help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.