TLS security on exchange 2010 ,

TLS security on exchange 2010 ,

I am attempting to convert a 2003 exchange to a 2010 exchange and the only connector I see is a connector named “TLS_ dedicated connector”  

The only confirmed items I see is under advanced ,outbound security  TLS security is checked and the anonymous access is also selected

Also the   “address space” tab contains several domain names,


If I  confireure every tab seen here the same in 2010 exchange will all work , I assume I can test the mail on the new exchange by simply sending a email to one of the domains in the address space is there anything I am missing like a cert or anything , any advice on this would be helpful ,

Thanks!!!!
 TLS TLSS
LVL 1
NAMEWITHELD12Asked:
Who is Participating?
 
Glen KnightCommented:
No you don't Exchange 2010 will use oportunistic TLS so as long as it's enabled (which it is by default) it will be attempted.
0
 
NAMEWITHELD12Author Commented:
http://technet.microsoft.com/en-us/library/bb430753.aspx

i have reseached this some more and i have found out that you do not have to configure anything as far as i can tell

"In earlier versions of Exchange, you had to configure TLS manually. In addition, you had to install a valid certificate, suitable for TLS usage, on the server running Exchange. In Exchange 2010, Setup creates a self-signed certificate. By default, TLS is enabled. This enables any sending system to encrypt the inbound SMTP session to Exchange. By default, Exchange 2010 also attempts TLS for all remote connections"
0
 
NAMEWITHELD12Author Commented:
where would you find the setting for operunistic TLS , so I can confirm , this is good news it seems like all I will have to do is test it

thanks!!!!!!
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Glen KnightCommented:
You don't have to set it, it will try TLS automatically if it's checked and then fail if it's not available to non-TLS
0
 
NAMEWITHELD12Author Commented:
yeah but i was just wondering were the check box it , just for my education
0
 
Glen KnightCommented:
I apologise, I misunderstood your question.

Under Organisation Configuration > Hub Transport > Send Connector

Right click the send connector and select properties.  Under the Network tab put a check in the box that says "Enable Domain Security (Mutual AUTH TLS)"
0
 
NAMEWITHELD12Author Commented:
Thanks !!!!!!!!!!!!!!!!!!!!!!!
0
 
Steve TinsleyCommented:
Does TLS on exchange 2010 only work when sending email via DNS rather than using a smarthost?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.