Windows time on a 2008 r2 sp2 server

If i manually update the time on my PDC it instantly reverts back to the time before i changed it.
Why will it not keep the time i tell it? It is off about 8 minutes. faster the the official us time.
your expertise is appreciated. thanks.
4CHailAsked:
Who is Participating?
 
wantabe2Commented:
Then your PDC is getting it's time from an unreliable time source. You can edit the registry on the DC that holds the PDC enumerator FSMO role to point to a correct time source. Here is a .reg file you can import into your registry on the PDC enumorator to point the time to time.gov

Make sure you change the .txt to a .reg before you run it. After you run it either reboot the server or restart W32time service.
0
 
wantabe2Commented:
For changing the time you will just need to log into whatever server you have as the PDC and fix the time there and it should roll out to the rest of the network. It will take a few minutes before all the other DCs get the time change.


You can determine which server hold this role by following these directions:

http://www.petri.co.il/determining_fsmo_role_holders.htm

0
 
4CHailAuthor Commented:
I have done that. the problem is that when i change the time on the pdc it immediately reverts back to the incorrect time. how can i make it keep the time i set it to?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
4CHailAuthor Commented:
Im sorry. where is the .reg file?
0
 
wantabe2Commented:
0
 
wantabe2Commented:
By the way, to give credit due, this .reg file was given to me from this site. I think it was dariqus who originally posted it a year or so ago.
0
 
4CHailAuthor Commented:
i have changed the time source. The time is sill not correct with www.time.gov central time.
i cannot find the server for us time to put in my settings. do you know that one?
thanks.
0
 
4CHailAuthor Commented:
sfsdf
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.