Solved

Vista and WEP

Posted on 2011-03-09
4
598 Views
Last Modified: 2012-05-11
I have a client who uses WEP for all of their 10 offices. All of the offices have the same SSID with the same WEP key. They can walk into any office and connect with no reconfiguration.

I have walked into this situation. We all know that WEP is the LAST thing you want to use. Every question on this specific topic here on Experts Exchange has been answered by someone saying ... "USE WPA or BETTER!" That's not an answer.

This time I would like someone to ANSWER the question at the heart of the problem.

I have many people who CAN access the wireless using the WEP key with XP and Windows 7. But I have 2 who cannot which are using Windows Vista.

I tried a few fixes like disabling IPv6 on the adapter and going into the registry and turning the DhcpConnForceBroadcastFlag to "0". Nothing has worked.

When I make the router in an office use WPA in testing, it connects instantly. When I turn it back to WEP, it connects but gives me the generic 169.x.x.x address.

For those who say, go to WPA, we would have to go to all the offices, change all the wireless routers and then re-configure EVERY user. Not going to happen. At least right now.

Need a fix for this specific problem.
0
Comment
Question by:snobrdrt
  • 2
4 Comments
 
LVL 4

Accepted Solution

by:
CHutchins earned 500 total points
ID: 35089116
GO TO WPA already :D

This is a guess but I imagine its an issue with the software or driver on the Vista machine.

If you are using the default  windows wireless try updating the driver.  If that doesnt work try using the wireless cards app.  
0
 
LVL 1

Author Comment

by:snobrdrt
ID: 35089204
Hahaha. I hear ya!

I'm a long time IT guy just for info purposes. So I've tried uninstalling, reinstalling, new drivers, old drivers ... the only think I have not tried is pulling out the Intel wireless application. I'll give it a try but the PROBLEM is something inherent to Windows Vista and WEP marriage.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 35107625
Are you using a passphrase to enter the WEP key, or just standard HEX?  The latter is usually better.

Try using 40-bit WEP instead of 128-bit.
0
 
LVL 1

Author Closing Comment

by:snobrdrt
ID: 35212458
No real solution to actual problem BUT WPA was the real way to go, even though that path is a very large project.
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Working settings for French ISP Orange "Prêt à Surfer" SIM cards for data connections only. Can't be found anywhere else !
This subject  of securing wireless devices conjures up visions of your PC or mobile phone connecting to the Internet through some hotspot at Starbucks. But it is so much more than that. Let’s look at the facts: devices#sthash.eoFY7dic.
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question