Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 930
  • Last Modified:

Oracle11g: new install: sqlplus: 'error while loading shared libraries...' any ideas?

Hello Experts,

I just installed Oracle11g R2. Now, trying to connect via sqlplus to start instance of db. but I get error below, any ideas what the problem may be?

[oracle@oracle bin]$ ./sqlplus "/ as sysdba"
./sqlplus: error while loading shared libraries: /oracle/lib/libclntsh.so.11.1: cannot restore segment prot after reloc: Permission denied

thanks for all of your help...

regards,
0
epifanio67
Asked:
epifanio67
  • 4
  • 4
1 Solution
 
Alex MatzingerDatabase AdministratorCommented:
this may be a SELinux error if you are on Linux...try disabling it and see if that works.  If you aren't on linux...what operating system are you using?
0
 
epifanio67Author Commented:
thank you expert,

I just disable it; but still getting same results...
these are all variables set:
ORACLE_SID=orcl
ORACLE_BASE=/home/oracle/app/oracle
ORACLE_HOME=/oracle
TMPDIR=/oracle/tmp
TMP=/oracle/tmp
LD_LIBRARY_PATH=/oracle/bin:$PATH

any other ideas?

thanks so much....

regards,
0
 
Alex MatzingerDatabase AdministratorCommented:
Try running this command:(again if you already did it)

setenforce 0

Open in new window


and then typing
tnsping orcl

Open in new window


and post your results back here
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
epifanio67Author Commented:
thank you experts,

same error:
./tnsping: error while loading shared libraries: /oracle/lib/libclntsh.so.11.1: cannot restore segment prot after reloc: Permission denied

odd... there was no issues with the install and/or creation of db
0
 
Alex MatzingerDatabase AdministratorCommented:
Ok, you need to log in as root and run this command

getenforce 

Open in new window


and post the results back here
0
 
epifanio67Author Commented:
thank you expert,

[root@oracle bin]# /usr/sbin/getenforce
Enforcing

don't understand... I update /etc/selinux/conf

0
 
Alex MatzingerDatabase AdministratorCommented:
ok, stay logged in as root(or re log in as root) and re run these two commands.
setenforce 0

getenforce
 

Open in new window


if getenforce reports Permissive or disabled at that time, then try logging into SQL plus again.  If gentforce still reports enforcing then post back here with your exact version of linux.
0
 
epifanio67Author Commented:
thank you experts so much...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now