linux ACL question

I have created a file called lab2 and gave access to userID mark, but after su to mark, I  don't have permission to write contents on lab2 file. What am I missing here?

 getfacl lab2
# file: lab2
# owner: ghuru
# group: ghuru
user::rw-
user:mark:rw-
group::rw-
mask::rw-
other::r--
mokkanAsked:
Who is Participating?
 
farzanjConnect With a Mentor Commented:
Show me

ls -l lab2
0
 
mokkanAuthor Commented:
[root@localhost ghuru]# ls  -l lab2
-rw-rw-r--+ 2 ghuru ghuru 0 Mar  9 19:03 lab2


Is this file system should mount with ACL option?
0
 
farzanjConnect With a Mentor Commented:
Yes, in your fstab, is it mouted with acl in the options?

If not try doing this

mount -o remount,rw,acl -t ext3 /dev/... /mount/pt

Also for now, try doing chmod 777 lab2, just to make sure
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
mokkanAuthor Commented:
ah ok, thank you. Let me try.
0
 
cycotr0nConnect With a Mentor Commented:
Just an FYI - Sometimes you don't need the acl option in fstab if it is specified in the filesystem's default mount options.  You can check with dumpe2fs:

# dumpe2fs /dev/sda1 | grep mount
dumpe2fs 1.39 (29-May-2006)
Last mounted on:          <not available>
Default mount options:    user_xattr acl
Last mount time:          Thu Feb  3 09:21:52 2011
Maximum mount count:      -1
0
 
farzanjConnect With a Mentor Commented:
Thanks for the info.

So is your issue resolved?  Need any more help?
0
 
mokkanAuthor Commented:
Thank you all of you. It worked now.,
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.