FireFox not working

A member of staff ran a FireFox update on a Terminal Server and now we get "your computer must be restated to complete a previous upgrade of FireFox. Do you want to reboot now?"
Re-booting the server is of no help, if I atempt to uninstall FireFox I get the same message. How can I remove FireFox from the Terminal Server?
waca-itAsked:
Who is Participating?
 
mrroonieConnect With a Mentor Commented:
specifically this part - Long story short: delete the *.moz-upgrade and *.moz-delete files from Firefox folder. Now that the error is gone, I went ahead and uninstalled/reinstalled Firefox just to make sure nothing dirty was left behind.

0
 
b_nassliCommented:
removing all trace of Firefox, un-installed, looked for folders and deleted them and removed every registry key that looked remotely related to firefox. After this the firefox installer, and reinstaller
0
 
amit_ld2010Commented:
start task manager by ctrl+alt+delete.
open process tab.
find firefox.exe
delete that process and try to run again
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
mrroonieCommented:
i had this problem on one of my client machines, but it was a local machine rather than logging into terminal services. i fixed it by logging in with an administrator account to let the update complete properly, or giving the user admin rights to complete the upgrade, then removing the users admin rights
0
 
Chev_PCNCommented:
1) Make sure that the user session switches to TS Install mode. (change user /install)
2) The installing user should have at minumum Power User group membership (preferably Local Admin).
3) Right-click the installer & select "run as administrator".
4) Once install is complete, Revert user session to "run" mode (change user execute)
5) Reboot if required & test.
0
 
Chev_PCNCommented:
Just some clarification.
Points 1 & 4 should be run from a cmd prompt with administrator rights & the second command is in fact "change user /execute"
0
 
waca-itAuthor Commented:
Thank you all for your help, I will try them all after hours and see what happend. My users are not happy with "use IE" any more!!!!
0
 
waca-itAuthor Commented:
I have tryed all the sugestions, non have fixed the problem
0
 
oldstone00Commented:
switch to chrome
0
 
waca-itAuthor Commented:
It is all well and good to switch to Chrome; however, the problem is still not fixed. I would be happy just to be able to un-install FireFox, this I am unable to do.

At this stage, I just want to get rid of the problem.
0
 
Chev_PCNCommented:
Try this:
Disable & stop the RDS services.
Boot the server into Safe mode.
Do your uninstall / re-install.
Set RDS services to Automatic again.
Reboot to Normal mode.
0
 
mrroonieCommented:
this link may help you - http://www.ecimulti.org/blog/?p=49
0
 
waca-itAuthor Commented:
It is fixed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.