[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2605
  • Last Modified:

DNS unable to resolve

Hi everyone,

I’m trying to setup a server Win2008 with IIS on for webapplication, called “Host1”. I have 2 VLANS, one for the server farm (20.x.x), and one for clients(192.x,x), they’re both connected to the internet. And both Vlans use the same DNS server.

For an unjustifiable reason, I can only place this server on the clients VLan.

My problem is:

I can access the web application (http://host1) from 20.x.x.x just fine.

However when I try to access the same application from the clients Vlan, I get an error on Internet Explorer “Network Error (dns_unresolved_hostname) Your requested host "Host1" could not be resolved by DNS.” I tried using http://host1, http://host1.mydomain.com, and also tried http://host1:8080... I couldn’t try using http://192.x.x.x because my ISP doesn’t allow me to browse using IP address.
I checked my DNS, I do have an A host record of the server. I even tried to manually add it to the hosts file on my XP machine. I can ping and NSlookup just fine from all machines.

My conclusion is as follows:
When Client workstation tries to connect to the web application, it goes straight to the Internet’s DNS to check the host name, that is why I am getting a DNS unable to resolve error.

Please correct me if I’m wrong, I’m very frustrated. I need your Help!
0
ahmedals
Asked:
ahmedals
  • 2
1 Solution
 
Chev_PCNCommented:
Your browser should be using the DNS settings specific to the local machine. On a workstation or server showing this problem, what result do you get back if you open a cmd box & run "nslookup host1"?
You say you have 1 DNS server. Do you have multiple zones on that DNS instance?
If so, try adding Host1 to both zones, e.g. host1.server.farm and host1.clients.net.
0
 
bitlaCommented:
On the client PCs in the TCP/IP properties add DNS ip address of the host1 domain and also make sure there is forward and reverse lookup zones for the Host1 in the DNS Server.
0
 
ahmedalsAuthor Commented:
Hi Guys,

Thank you for your comments. I have already done that previouslym but still didn't work.

I found a solution to my problem.

I had forgotten to put an exception on my BlueCoat proxy device, thats why it was denying it access.
0
 
ahmedalsAuthor Commented:
I had forgotten to put an exception in my proxy server.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now