Problem configuring mod_ssl

OS= Linux
I have installed apache 2.2.17
Installed openssl-1.0.0d
And tried to configure mod_ssl-2.8.30-1.3.39 using command -

./configure --with-apache=../httpd-2.2.17 --with-ssl=../openssl-1.0.0d --prefix=/apps/elsdev/apache

It gave me error -

Configuring mod_ssl/2.8.30 for Apache/1.3.39
./configure:Error: Cannot find Apache 1.3 source tree under ../httpd-2.2.17
./configure:Hint:  Please specify location via --with-apache=DIR

why mod_ssl is looking for older apache version while I am using 2.2.17?
RazAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dfkeCommented:
Latest mod ssl 2.8.31 is for Apache 1.3.41

I think you must change the Apache version in /custombuild/configure/ap1/configure.apache_ssl:

to

--with-apache=../apache_1.3.39 \

then try again

0
Hernan RuggianoCommented:
Mod_ssl is tied to the apache version, so basically you just downloaded the wrong package.

http://www.octaldream.com/~scottm/talks/ssl/mod_ssl.html

Download the right package, and with that sintax you should be ready to go.

Regards,
Hernan
0
RazAuthor Commented:
Hi Dfke & Hruggian,

Thanks for the suggestions.
=======================================
Dfke,

As you said,

Latest mod ssl 2.8.31 is for Apache 1.3.41
But I am using Apache 2.2.17
So, does it mean the there is no compatibl mod_ssl for Apache 2.2.17?
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

RazAuthor Commented:
Dfke,

You have suggested to change the version in some file.
I am unable to figure it out. Could you please specify which needs to be modified and where?
Is it in apache home or mod_ssl home?

Thanks in advance.
0
RazAuthor Commented:
I have found in the below link that we can use --force to make the mod_ssl compatible with apache 2.2.17 forcibily. Is it safe to do that?

I tried it as below. It didnt work.

$ ./configure --force --with-apache=../httpd-2.2.17 --with-ssl=../openssl-1.0.0d --prefix=/apps/elsdev/apache
Configuring mod_ssl/2.8.30 for Apache/1.3.39
./configure:Error: Cannot find Apache 1.3 source tree under ../httpd-2.2.17
./configure:Hint:  Please specify location via --with-apache=DIR
 
0
dfkeCommented:
I think your best shot is to recompile Apache as the package has it's own mod_ssl rather than trying to add mod_ssl later on. You can compile it in by specifying --enable-ssl on the configure command when compiling Apache.

./configure --enable-ssl --enable-so

If you've added --enable-ssl, it will be compiled in statically. If you want a DSO (Dynamic Shared Object), add --enable-mods-shared='ssl' to the configure command.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.