Tame DOS, problem with keypad decimal

I'm using Tame DOS in an installation to get a DOS program to run under Win7 - that part works ok.

But now I've banged my head against another wall: keyboard layout.

It's using the correct keyboard setup (which is danish), but the numpad is using the wrong decimal caracter. Instead of the comma as used in Denmark, it insists on using a period as decimal separator.

Everything else is working, including the special nordic signs. And the comma and period is working as suspected on the main part of the keyboard.

Any suggestions to how I overcome this problem?
ellegaarddkAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
ellegaarddkConnect With a Mentor Author Commented:
This line in the application setup file solved the problem:

 /MacroDef OnKey = Num.     Options=(/SendInput unicodeChar=#002c)

Open in new window

0
 
Miguel Angel Perez MuñozConnect With a Mentor Commented:
try this:

keyb dk
chcp=850

Maybe need to load keyb in config.sys but its an emulated system...
0
 
AmickConnect With a Mentor Commented:
If Drashiel's solution doesn't work maybe a key remapper like KeyTweak would help.
0
 
ellegaarddkAuthor Commented:
I've tried the setup of keyb and codepage, but no luck. Seems to be a fault in the definition of a scandinavian keyboard...

I finally figured out how to have the program itself exchange any NumPad periods transferred to the applikation as a comma.

Can remember the soloution right now, but I'll be back with it.
0
 
ellegaarddkAuthor Commented:
The solution was in the setup of the applications ini-files used by Tame, which none of other comments hinted at.

I give them some point as a token of my gratitude towards their intentions  ;)
0
All Courses

From novice to tech pro — start learning today.