Solved

My Black Berry Monitoring server Web Console is just showing blank screen

Posted on 2011-03-10
20
1,169 Views
Last Modified: 2012-05-11
Hi,

My Black Berry environment is:

BAS server 1
BAS Server 2
BES Primary
BES Standby

my BAS web console is working fine

My Monitoring web console is not opening, just showing white blank screen

Please help.

Best Regards,
Amir.
0
Comment
Question by:Amir4u
  • 10
  • 6
  • 4
20 Comments
 
LVL 12

Expert Comment

by:Shekhar2cool
ID: 35096693
0
 

Author Comment

by:Amir4u
ID: 35097255
thanx and I tried both but still white page coming when i try to login.
0
 
LVL 12

Expert Comment

by:Shekhar2cool
ID: 35097382
Can you see the logs, if you find something there
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Author Comment

by:Amir4u
ID: 35097452
(03/10 12:40:08:110):{Timer-0} [com.rim.bes.bms.system.BMSManager] [BBMS-3001] {unknown} Failed to login to BAS

(03/10 12:31:06:341):{Timer-0} [com.rim.bes.bms.system.BMSManager] [BBMS-3001] {unknown} Failed to login to BAS


this is from today's BBMS log
0
 
LVL 12

Expert Comment

by:Shekhar2cool
ID: 35099155
Try this :

copy the value from the following key
 

HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry Enterprise Server\Dispatcher\BippePassword

 

and paste the value into the following key

 

HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry Enterprise Server\Monitoring Service\BippePassword

 

Then restart the monitoring console service and check
0
 

Author Comment

by:Amir4u
ID: 35099261
Did that already ....still the web console web page is white out ...
0
 
LVL 12

Expert Comment

by:Shekhar2cool
ID: 35099336
I believe then you will have to go for a Fresh Install
0
 

Author Comment

by:Amir4u
ID: 35108951
so no other option?

i installed it two times, always used existing database and installation didnt give any error.

I am also in touch with BB Support and they have asked wireshark packet capture and logs which i gave two times.

i cant believe it will become that bad......
0
 
LVL 14

Expert Comment

by:Mike Sullivan
ID: 35112734
Do you have any security device that is monitoring and filtering LAN traffic? Eg. ISA Server?
0
 

Author Comment

by:Amir4u
ID: 35128452
we have firwalls but they dont interfare in the communication between BES/BAS/BMS ...the firwalls are on the network edge.
0
 
LVL 14

Expert Comment

by:Mike Sullivan
ID: 35128476
Is the back-end SQL database on a fixed or dynamic port?
0
 

Author Comment

by:Amir4u
ID: 35128568
it's on a static port 5155.
0
 
LVL 14

Expert Comment

by:Mike Sullivan
ID: 35128632
OK, back to basics. This is a web-based monitoring tool that isn't loading correctly.

Are you using Internet Explorer or a different web browser? Can you try it with IE?
Does IE recognise the site as being in a Trusted or Intranet Zone?
Have you downloaded the security certificate from the website and installed it as a Trusted Root Authority?

Before we proceed, we need to know that the website opens with no prompts and no visible security errors.
0
 

Author Comment

by:Amir4u
ID: 35129032
Thanx for help..

I am using IE and it is version 7 as per BB official docs

It is already added in trusted zone

security certificate info can be bypassed and it did login few times and i did work inside the webconsole but then as the session timed out, thats it, i would not be able to login for long time and then after running keystore password process as per BB docs  it would let me in again mysteriously and again to the same cycle, as soon as session times out, i'm out for good...

now BB support is scatching their heads as well...
0
 
LVL 14

Expert Comment

by:Mike Sullivan
ID: 35131018
Ok, don't try to bypass the security certificate info. Add it as a trusted root authority to rule it out of the equation and try connecting to the HTTPS port.

Are you using the standard ports for the BlackBerry Monitoring Service? Ie. 5088 for HTTP and 5089 for HTTPS? Can you try configuring them to use alternate port addresses and see if that works around the problem?

Configure the web server attributes of the BlackBerry Monitoring Service
1. On the Configuration tab, click the Web server tab.
2. Complete the following fields:
Bind Address: Type the IP address to which you want the web server to bind. If you leave the field empty, the web server binds to all available addresses.
Bind Port: Type the port number to which you want the web server to bind when using Hypertext Transfer Protocol (HTTP). By default, the web server uses port 5088.
Secure Bind Port: Type the port number to which you want the web server to bind when using Hypertext Transfer Protocol over Secure Sockets Layer (HTTPS). By default, the web server uses port 5089.
Protocol: Select whether the web server should use HTTP or HTTPS. By default, the web server uses HTTP.
3. Click Update.
4. Click Restart.
0
 

Author Comment

by:Amir4u
ID: 35131292
Ok i will try to not bypass certificate although it is normal and my BAS is working fine that way but I udnerstand it's for troubleshooting purpose.

About the instructions for using alternate port addresses please tell me where to configure that ?
0
 
LVL 14

Expert Comment

by:Mike Sullivan
ID: 35131702
Apologies, that was for v.4. You've already stated that you are using v.5.

OK, next. Find the Monitoring Service logs. They are usually in C:\Program Files\Research in Motion\BlackBerry Enterprise Server\Logs

Do you see something that looks like this:

[info] Procrun (2.0.3.0) started
[info] Running Service...
[info] Starting service...
[174  javajni.c] The specified module could not be found.
[986  prunsrv.c] Failed creating java \jre\bin\client\jvm.dll
[1260 prunsrv.c] ServiceStart returned 1
[info] Run service finished.
[info] Procrun finished.
0
 

Accepted Solution

by:
Amir4u earned 0 total points
ID: 35137886
thanx for helping mike but the problem is resolved.

When the problem started i was troubleshooting on one BAS server and i was not invilving at all BAS server 02.

When I made the password change for "Black Berry Configuration" in "Secure Connection" i did it only for BAS 01 and not BAS 02.

Also I upgraded BMS with MR4 but did not do it in all my BAS/BES servers.

So BB support told me to make the changes in both and then try.

Now at least the console started appearing.

But i still could not log in with my credentials.

then I upgraded all BAS/BES to MR4 and then restarted the BMS and now i was able to login easily.

So it's resolved now.
0
 
LVL 14

Expert Comment

by:Mike Sullivan
ID: 35138639
Excellent. Glad you've got it sorted.
0
 

Author Closing Comment

by:Amir4u
ID: 35178739
solved by our BB support though I really appreciate the help given by EE members.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help those of you having problems with the Nextel Blackberry 8350i.  Recent Software updates cause the problems issues described below, and this article will help you revert back to the older software. As we know, Nextel has alw…
For many people, the BlackBerry is an indispensable tool during their working day. The ability to have your emails delivered swiftly and securely to your hand can improve your personal efficiency immensely. So, how many people do you see with their …
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question