[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 262
  • Last Modified:

Wordpress sub directory install error

I've intalled wordpress to mydomain.com/blog/

I'm able to log in, but when I go to view any page/post I get a redirect error saying that the loop will never complete

I'm currently running asp on the main site.
The IIS site documents are listed in order as index.asp then index.php.

0
m2ew
Asked:
m2ew
  • 2
  • 2
1 Solution
 
jeremyjared74Commented:
Go to Settings>Permalinks and set the settings to default. Then update. Even if it is set to default you may need to click save to update the permalink structure.

Second thing to try would be to check your url in the Settings>General area. Make sure the site URL reflects the sub-folder.
0
 
m2ewAuthor Commented:
I did check the permalinks. The only solution I found was to use the Disable Canonical URL Redirection plugin.

http://txfx.net/files/wordpress/disable-canonical-redirects.phps
0
 
jeremyjared74Commented:
I always use Linux servers so I am not as familiar with IIS as with Linux. I know from working with a client about a year a go it is possible. I just don't remember exactly how I did it. Here is a link to a site that explains how to permanently re-direct with IIS server. It isn't the same way I did, but sounds like it will work:
http://www.barrywise.com/2008/10/seo-canonical-urls-and-301-redirects-in-windows-iis-6-iis-7/
0
 
m2ewAuthor Commented:
It was the only working solution I could find to fixing IIS and wordpress redirect issue.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now