[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 614
  • Last Modified:

Remote desktop session does not close properly via vpn connection

we are using a sonicwall 4200 to allow an external guest user to connect via rdp to one of our applications.  all works fine until the user is finished and wants to exit the system.  after using the applications "Exit" button to close all application windows, the remote windows (gray screen) dialog area remains open.  "x" out warns of disconnecting, this is what users will end up doing.  I have the ussers a/d "sessions" set to end a disconnected session in 1 minute but this does not happen.  I checked and ts is configured for users config.
any suggestions welcome.
Thanks
Wayne
0
wlasner
Asked:
wlasner
  • 5
  • 5
1 Solution
 
2CsCommented:
Are they disconnecting from their session or logging off the session?

Sorry didn't quite understand your question.
0
 
wlasnerDirector, ITAuthor Commented:
disconnecting
0
 
2CsCommented:
If you use TSADMIN and reset their session, is it resolved?

Get them to log off instead, disconnecting is the best solution. I don't think there is a simple way to deny users access to the RDP bar.

Is this Windows Server 2003/2008?

I think you might need to set idle session limit as well.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
2CsCommented:
Also what environment is your AD running in? 2003/2008?
0
 
wlasnerDirector, ITAuthor Commented:
2003
let me clarify, they have no choice, when they exit the application they are left with a blank screen with no options.  Normally the screen would close with the application, now it stay open until the user "X" out of it. .. disconecting the (frozen) session.
0
 
2CsCommented:
OK. Log into the server. Open Administrative Tools and then open Terminal Server Configuration (I think). Then set the properties in TCP/IP to override user settings and disconnected sessions to be closed after 1 min.
I tested on 2003/2008 in our environment using the AD setting you used an had the same problem with it not working. Above processed worked for me.

Al
0
 
wlasnerDirector, ITAuthor Commented:
OK, that makes sense but the option is grayed out.  The check box is available but the grayed out selection for the time does not open for editing.
0
 
2CsCommented:
Sounds like GPO is removing those options for you. Either local or domain level.
0
 
wlasnerDirector, ITAuthor Commented:
I will look into it
thanks
0
 
wlasnerDirector, ITAuthor Commented:
May have helped, not possible to acheive total goal.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now