Solved

Certificates won't work in Linked Pool with persistent drives

Posted on 2011-03-10
5
565 Views
Last Modified: 2012-05-11
When we deploy a pool of linked-clones using Windows 7, the IE certificates will not install correctly. The situation seems to be related to the moving of the profiles to the D: persistent disk. If I build a pool without configuring the use of persistent disks, I can successfully add a certificate for a website.

 
We have built the Windows 7 gold image as a workgroup using an administrator user. The View Composer joins the pool to the domain.

 
I have searched extensiviely and can't find anyone indicating that they are experiencing this problem. Any help is greatly appreciated.

 
Our environment is esxi 4.1u1 and view composer 4.5.
0
Comment
Question by:InfoSysNetworks
  • 3
  • 2
5 Comments
 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 35099766
http://paulslager.com/?p=717 you've looked through this article? and everything is okay? he did mention that each drive can only have 1 partition (view composer limitation)
0
 

Author Comment

by:InfoSysNetworks
ID: 35110957
I reviewed Paul's document and we have followed his procedures. The second partition I was referring to is the persistant user disk that View Composer creates.

I believe the problem has to do with where windows 7 thinks the certificate store should be, because if I login as a local administrator (whose profile is on the c drive), the certificate will install.

Do you know how windows keeps track of where the certificates store is to be located?
0
 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 35118638
you might want to use a gpo to install the certificate http://unixwiz.net/techtips/deploy-webcert-gp.html
0
 

Accepted Solution

by:
InfoSysNetworks earned 0 total points
ID: 35130709
It turns out that after you have composed the linked-pool clones with persistent drives, you have to specify where to import the certificate during the importation process.

So, if you have a certificate ready to import, right click, choose import. When prompted for where to import to, choose browse, then choose show physical location. Now, when you expand the Trusted Root Certificates, you will have an option for Registry.

Once imported to the registry, the certificate works.

Thank you for your suggestions
0
 

Author Closing Comment

by:InfoSysNetworks
ID: 35170935
Solved this problem through trial and error.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question