Solved

email relay works on XP but not on Windows 7

Posted on 2011-03-10
5
437 Views
Last Modified: 2012-05-11
We have a software package that uses email relay to send out receipts.  We set up the process once in the software package and then just make sure the select few IP addresses are added to Relay in Exchange.  This process has worked well for several years using XP machines.  We have just started using some Windows 7 machines and the email relay doesn't work on them.  I've added their IP addresses to Relay in Exchange, but they still don't work.  In fact one PC kept its static IP and the other one got a new IP address.  I removed and added both back in.  Is there something that needs to be done on the Win 7 side to make this work??  
0
Comment
Question by:cindyfiller
  • 2
  • 2
5 Comments
 
LVL 74

Accepted Solution

by:
Glen Knight earned 500 total points
ID: 35099591
There's no reason why this shouldn't work, but you might want to check the binding order of the network card.

So goto Change Adapter Settings.  Activate the hidden menu by pressing the ALT button.  Under Advanced select Advanced Settings.  Under the network card that is being used move IPv4 to the top of both lists.
0
 
LVL 18

Expert Comment

by:Andrej Pirman
ID: 35099656
Try diagnostics via command prompt:
Run CMD
Then type TELNET
New command prompt shows up. Type:
o 192.168.1.10 25  (this is "o" like OPEN, then IP of Exchange server, then port 25)
Exchange server should respond with something like this:
220 SERVER.domain.local Microsoft ESMTP MAIL Service ready at

If you get such a response, then e-mail settings on client are wrong. Maybe authentication, IP, port or else.
But if your exchange does not respond, then look into Win7 firewall and open port 25/SMTP for local domain network.
0
 
LVL 18

Expert Comment

by:Andrej Pirman
ID: 35099669
Oh yes...and check, if your Win7 client is in WORK or DOMAIN network (under "network and Sharing Center", Type of netowork. It should NOT be PRIVATE or HOME!
0
 

Author Comment

by:cindyfiller
ID: 35099825
Everything was listed ok in the advanced settings so I tried something else and it appears to have worked.  Under the local area connection properties I unchecked the internet protocol version 6.  I had originally tried the static ip there and it didn't work so I moved it down to the ipv4.  Your information led me to this idea so thanks a million.  It was the fastest response I've ever gotten and really helped!!!
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35099858
Excllent, glad it worked out ;)
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question