Printing very slow to a Rich Aficio MP C6000

I have an office with 15 or so with XP Pro (32 bit) and Windows 7 Pro (64 bit) workstations on a domain.

I have a Ricoh Aficio MP C6000 multifunction printer with stapler.

When I send a 48 page booklet, PDF, 2MB, color, (11x17, folded, stapled) to the printer with an XP machine, no problem.  With the Windows 7 workstations, printing is very slow, with many "waiting for print data" status messages on the printer display.  On a good machine, it prints in maybe four minutes.  On a Windows 7 machine, around 15.

I've tried the Ricoh universal print driver, along with various PCL5c and PCL6 64 bit drivers for that specific printer.  No luck.  I've tried printing the PDF as an image - didn't work.

Any ideas?
LVL 1
DaveWWWAsked:
Who is Participating?
 
dailypcguyConnect With a Mentor Commented:
Have you tried disabling AV software on the win 7 nodes temporarily?
What server are you using? I saw this in another thread on technet:

"You could also try disabling TCP Chimney Offload, RSS, Receive Window Auto-Tuning Level on Windows Server 2008 one by one to see whether it makes any difference.

 To disable TCP Chimney Offload, follow these steps:

 a.   Use administrative credentials to open a command prompt.

b.   At the command prompt, type the following command, and then press ENTER:

       netsh int tcp set global chimney=disabled

 To disable RSS, follow these steps:

 a.   Use administrative credentials to open a command prompt.

b.   At the command prompt, type the following command, and then press ENTER:

       netsh int tcp set global RSS=disabled

 To disable 'Receive Window Auto-Tuning Level', follow these steps: :

 a.   Use administrative credentials to open a command prompt.

b.   At the command prompt, type the following command, and then press ENTER:

       netsh interface tcp set global autotuninglevel=disabled

Try one at a time and see if any make a difference. If no change then try either of these two solutions in print management for win serv 2008 make sure that

"Solution 1 as posted there:
launch Print Management

Select a printer
right click, Manage sharing
uncheck the following option: Render print jobs on client computers

Solution 2:
launch Print Management
Select [the] printer
right click, printer properties , Advanced, uncheck Enable advanced features."

Good Luck

0
 
DaveWWWAuthor Commented:
Thanks.  That really seemed to speed up the printing... *after* I discovered my real problem: a bad network connection! :-)
0
 
dailypcguyCommented:
Good, glad you got it sorted. It was starting to sound like a hardware hiccup if you follow the KISS protocol ;-) It always makes me laugh when I spend hours trying to solve a problem that should really have been fixed by 'step 2 - check the physical'
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.