Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Ubuntu Serial ports setup

Posted on 2011-03-10
3
Medium Priority
?
1,581 Views
Last Modified: 2012-05-11
Hi guys,

Setup:
- PC with Ubuntu 10.10
- 1 built-in serial port
- 1 PCI card with two serial ports.
- An application that acquires data from devices that have serial ports.
- Application serial port requirements: Baud Rate: 115200, Stop Bits: 2, Parity: Odd, Flow Control: none

This setup is perfectly working under Windows with this three serial ports.

Under Ubuntu only the built-in serial port (ttyS0) is acquiring data, but the two serial ports (ttyS1 and ttyS2) from the PCI cards.

Terminal Output:

root@ubuntu:~# sudo dmesg | grep tty
[    0.000000] console [tty0] enabled
[    1.797328] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.797635] 00:07: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.818658] 0000:03:01.0: ttyS1 at I/O 0xdce0 (irq = 17) is a ST16650V2
[    1.839640] 0000:03:01.1: ttyS2 at I/O 0xdce8 (irq = 18) is a ST16650V2



What can I do in order to configure those settings for the two serial ports from the PCI card?

Thanks
0
Comment
Question by:vianneyjs03
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 15

Expert Comment

by:DonConsolio
ID: 35104174
Looks like ttyS1  and ttyS2 are detected correctly by Linux.

Might be a handshake problem.
Try using the "minicom" program to verify connectivity (set handshake to none - <Ctrl-A> <O> )
0
 

Author Comment

by:vianneyjs03
ID: 35104314
Hi DonConsolio,

Isn't minicom a terminal like Hyperterminal?
I used gtkterm (a GUI based terminal), and I was able to verify the connectivity.

I only need to change the tty1 and tty2 to meet my application's requirements.


Thanks.
0
 
LVL 15

Accepted Solution

by:
DonConsolio earned 2000 total points
ID: 35107403
What is the your application's way of setting handshake?
Try setting handshake to something like none/no/ignore.
0

Featured Post

Tech or Treat! - Giveaway

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question