no connection to bes agent

old BESX install removed from  server 2003 running 5.0.1 running fine.  Changed other server on the domain to new 2008 and exchange 2010 machines.

Download BESX 5.0.2 and fresh install of everything no old sql or anything. initially could not login once install completed. i the  ran a sql script to creat a user called admin and password blackberry on the BAS.  this worked ok and can now login.

Detected phone ok and added user but cannot sync to phone.

get error: {user} RPC command failed - no connection to BES agent

also from eventvwr :

{username changed } MAPIMailbox::MAPIMailbox - OpenMsgStore (0x8004011d) failed, MailboxDN=/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=user, ServerDN=/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=NTSERVER02/cn=Microsoft Private MDB

any help please
Who is Participating?
Rob KnightConnect With a Mentor ConsultantCommented:

Have you assigned the BES Admin permissions to the Exchange 2010 server as per RIM documentation?

I believe on 2010 you have to change a client throttling feature as well?


sifenwickAuthor Commented:
what is the client throttling?
sifenwickAuthor Commented:
done all item in exchange 2010 config guide now.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.