Turn debugging off on cisco router

Hi experts

I've made the silly mistake of turning on debugging and terminal monitor on a Cisco 1800 series router I only have console access to (no telnet or SSH). The below commands were used:

Router# debug crypto verbose
Router# debug crypto isakmp
Router# term monitor

The router is running fine, however, due to continuous debugging output flooding the console, I'm unable to make any changes or enter any commands, even to turn debugging off.

The router is in a remote location and I do not have physical access to it, I can however get someone to reboot it but not much more than that.

What can I do to turn debugging off to be able to manage the router again? I do have a config backup from today when debugging wasn't turned on.

Appreciate all help.
netstarukltdAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
JFrederick29Connect With a Mentor Commented:
Type this:

u all

Then press enter (short for "undebug all").

Even if you don't see it being typed, just type it and hit enter.  The terminal logging should eventually stop.
0
 
shubhanshu_jaiswalCommented:
Just type undebug all in notepad and copy it till next line and paste it in the console...I hope your problem will be solved...
0
 
Istvan KalmarConnect With a Mentor Head of IT Security Division Commented:
you need :

ter no mon

and after you able to view the router buffer with:

sh logg

you able to rate-limit to the console:

http://www.cisco.com/en/US/docs/ios/12_3/configfun/command/reference/cfr_1g04.html#wp1080627
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
netstarukltdAuthor Commented:
The problem I have is that I cannot enter any commands due to debugging output flooding the screen. I continuously have text scrolling on the screen and no cursor to enter any commands.
0
 
Don JohnstonConnect With a Mentor InstructorCommented:
Sure you can. Just type in the commands and hit enter. You won't see them and the debug output will continue for a while (until the buffer clears).
0
 
Istvan KalmarConnect With a Mentor Head of IT Security Division Commented:
next time before you do debugging I advise to enable rate limit and see only the internal log buffer....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.