Time Sync issues Winows Server 2008

Hello,

I am working on this issue for a while now and I am not able to get to the bottom of my problem. I really hope someone can help.

I have two ESXi 4.1 hosts which run several VMs. I lately discovered that no matter which VM i start that the time is completely off. Not a litte about 7 hours backwards. It does not matter if I restart a DC - even the PDC, a member server or a stand alone server. All of them start with the wrong time. I just added for example a new member server and if it starts the time is 7 hours behind. I have to sync the time with the w32tm /resync command or restart the time service otherwise the time does not sync. I added this standalone server to the domain and the same issue. But the DC is acting as a reliable time source.
I also checked that the VMs do not sync their times with the ESX host. No errors in the Event Logs after the restart. Where do these VMs get the wrong time from? Or what do they sync their time with?

Can anybody please help because I am pulling my hair out over this issue.

Thank you
Mc2102
Mc2102Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

coolsport00Commented:
Have you configured an ATS in your domain? http://support.microsoft.com/kb/816042
If so, configure your ESX/i hosts to point to this server; make sure your VMs (as it seems you have) do not sync with the host in VMware Tools. Your VMs should then get time from the DC they authenticate with, as DCs get their time from the ATS.

Hope that helps.

~coolsport00
0
Mc2102Author Commented:
Hello,

I think I might have found something. I just booted one of the VMs and started into its BIOS and then time in there is matching the wrong time in the OS. Ok then I know now where the VMs get the incorrect time from but now the question is why are do the VMs have the wrong time in their BIOS. Are they syncing their time with the ESX host? I changed the time in the BIOS of the VM to the correct time but as soon I restarted the VM the time is off again.

Thank you
Mc2102
0
coolsport00Commented:
Is VMware Tools of this VM set to sync with the host? Have you configured your ESX host to sync with your domain's ATS?

~coolsport00
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

JRoyseCommented:
If you have a single esxi4.1 server I would adjust the time on the vmware esxi using the vsphere client, configuration tab, Software, Time Configuration.

Check to make sure ntp in running, if it is not, adjust the settings with properties, and tell the ntp service to start automatically.  Then adjust the time with the dialog box there.  

Make sure you have vmware tools installed on the guests.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
coolsport00Commented:
Also, here are some pretty good articles that discusses time sync'ing in more detail:
http://kb.vmware.com/kb/1318
http://www.vmware.com/files/pdf/Timekeeping-In-VirtualMachines.pdf

Regards,
~coolsport00
0
Mc2102Author Commented:
JRoyse might have got me the right idea. I have two ESXi 4.1 hosts and I checked the time server configuration and on one there was none at all and on the other one there where the DC configured as the NTP source. I am not to sure if that is such a good idea so I configured both ESXi hosts to point to a external NTP server - the same the PDC is pointing to and now the VMs seem to start with the correct times. But I want to do some more testing before I party. I will keep you guys updated.
0
Danny McDanielClinical Systems AnalystCommented:
when a VM boots it has to get the hardware time from somewhere because it doesn't have a real motherboard with a battery backed clock, so when it polls for time...it gets it from the ESX host.   Once the VM is up and running, then it can use NTP or other methods to get time from a network source.  Like JRoyse posted, check your host time and make sure it is set correctly (if it's red when you look at it, then it's saying that it's off with the client's computer time) and make sure you setup NTP to keep your host updated.

0
mccrackyCommented:
One of two things come to mind:

1. The timezone is incorrect on the host.

2. The ESXi host is set to UTC and your Windows hosts expect localtime (which, from your description is about 7hours different from UTC (US - Mountain Time?)) and the Windows guests receive their initial time from the ESXi host.
0
Mc2102Author Commented:
I fixed the NTP settings on the ESXi hosts and after they synced their time correctly with the NTP server the VMs also had the right time and all my issues went away.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.