Solved

vsftp Isuue

Posted on 2011-03-11
16
355 Views
Last Modified: 2013-12-06
Hello

I am not able to use ftp/sftp for user "dzschwz".Error is below

Failed
FTP Connection Failed:
3/10/2011 4:21:55 PM Bad sequence of commands.

root@lpv017 # cat vsftpd.conf
# Example config file /etc/vsftpd/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=027
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
chown_uploads=NO
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=NO
log_ftp_protocol=YES
#
# You may change the default value for timing out an idle session.
idle_session_timeout=1200
#
# You may change the default value for timing out a data connection.
data_connection_timeout=1200
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
nopriv_user=sshd
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
ascii_upload_enable=YES
ascii_download_enable=YES
#
# You may fully customise the login banner string:
ftpd_banner=Access to this Computer System is Strictly Regulated and Subject to Criminal Prosecution
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
chroot_list_enable=YES
chroot_local_user=YES
# (default follows)
chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=NO
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd whith two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES

pam_service_name=vsftpd
userlist_enable=YES
userlist_deny=NO
tcp_wrappers=NO
pasv_min_port=12000
pasv_max_port=12003

Open in new window

0
Comment
Question by:mnis2008
  • 7
  • 6
  • 3
16 Comments
 
LVL 40

Expert Comment

by:omarfarid
ID: 35110501
vsftpd is an ftp server. sftp is not using vsftpd

what command do you use?
0
 

Author Comment

by:mnis2008
ID: 35110676
root@csc06ftp # ftp localhost
Connected to localhost.localdomain.
220 Access to this Computer System is Strictly Regulated and Subject to Criminal Prosecution
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (localhost:root): dzschwz
530 Permission denied.
Login failed.
ftp>
0
 
LVL 31

Expert Comment

by:farzanj
ID: 35110740
Do this and show the output.  What is your OS?
 
telnet localhost 21

Open in new window

0
 
LVL 40

Expert Comment

by:omarfarid
ID: 35110758
why you have

userlist_enable=YES

set?

0
 

Author Comment

by:mnis2008
ID: 35110782
telnet localhost 21
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 Access to this Computer System is Strictly Regulated and Subject to Criminal Prosecution

According to the manpage userlist_enable=YES, Specifies that users in /etc/vsftpd.user_list are not allowed but userlist_deny=NO, specifies that users in /etc/vsftpd.user_list are only allowed..


0
 
LVL 40

Expert Comment

by:omarfarid
ID: 35110794
did you check if the username is not in  /etc/vsftpd.user_list
0
 

Author Comment

by:mnis2008
ID: 35110829
user is listed in  /etc/vsftpd.user_list
0
 
LVL 31

Accepted Solution

by:
farzanj earned 250 total points
ID: 35110840
Delete the name
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 
LVL 31

Expert Comment

by:farzanj
ID: 35110844
Remove this user from this list /etc/vsftpd.user_list.  See if you can do ftp
0
 
LVL 40

Assisted Solution

by:omarfarid
omarfarid earned 250 total points
ID: 35110846
you should not put the username there, delete it
0
 

Author Comment

by:mnis2008
ID: 35110849
userlist_enable = If enabled, vsftpd will load a list of usernames, from the filename given by userlist_file. If a user tries to log in using a name in this file, they will be denied before they are asked for a password

userlist_deny = This option is examined if userlist_enable is activated. If you set this setting to NO, then users will be denied login unless they are explicitly listed in the file specified by userlist _file
0
 

Author Comment

by:mnis2008
ID: 35110865
It works if I delete, So where should I define if the user wants to ftp.
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 35110870
why you need both

userlist_enable

and


userlist_deny

be enabled together?
0
 

Author Comment

by:mnis2008
ID: 35110913
I am not sure, I mentioned both because it was in the man page, If Userlist_enable is enabled then userlist_deny should be no.

So where should I define the list of users who wants to FTP to the server, what changes should be made in vsftpd.conf file
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 35110991
try to hash userlist_deny or setting it to YES

OR

set userlist_enable to NO
0
 

Author Comment

by:mnis2008
ID: 35113025
So by setting the either below, I should be able to add users in  /etc/vsftp.user_list to have them access to FTP

userlist_deny= YES
or
userlist_enable =NO
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Linux as a middle box 7 64
nagios alerts 3 33
Why isn't object file created? 6 43
how to install java on RHEL image on EC2 4 10
Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now