Solved

SBS2008 RWW fails first time, works the second time

Posted on 2011-03-11
7
883 Views
Last Modified: 2012-05-11
SBS 2008 server working great.  A couple months ago, we had a memory problem on the server so when people tried to access the site online (via RWW), it wouldn't let them in.  We fixed the memory problem, but ever since then, the first time from any browser on any computer that you go to https://remote.servername.org it returns an error:
The URL says:
https://remote.servername.org/remote/RWWErrorPage.html?aspxerrorpath=/Remote/logon.aspx

and on the page itself it says:
Cannot connect to the Remote Web Workplace site.  To continue, contact your Network Administrator.

If the person then simply tries https://remote.servername.org again, it works great!

This is replicable on any computer, whether or not it's ever tried to access the server before.
This really causes a lot of headaches for me because everyone tries it once and gives up.  How can I make it work the first time again?
0
Comment
Question by:mignonnedavis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35112798
This sounds like the application pool associated with SBS Web Applications is unloading itself when idle, and it takes a wake-up call to get it going again. What happens if you connect (twice), and then close all browser windows, wait 5 seconds, and then connect again? Does it still do the error, requiring you to reconnect?
0
 

Author Comment

by:mignonnedavis
ID: 35123527
Well if I close all browser windows and wait 5 seconds it connects first time.  In fact, it seems to connect the first time if it's under 10 minutes.  It seems to fail somewhere around 15 to 20 minutes.  
Any timeout somewhere I can play with?
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35123580
Open IIS Manager and expand your server, sites, and select SBS Web Applications.
In the Actions pane, click View Applications.
Find "/Remote" in the Virtual Path column and check which Application Pool it is using. Mine is using "SBS Web Workplace AppPool (v.20)".
Click Application Pools in the Connections pane on the left.
Select the Application Pool you found above.
Click Recycling and see what's in there. Mine is set to 1740 minutes, and only the "regular time intervals" box is checked. If you don't make any change, click Cancel.
Click Advanced settings. I've attached a screenshot of what mine looks like. Mine has some idle timeouts, but I don't have the problem you described. Maybe you'll find some other setting that is different.

If you don't find the answer here, I suggest you start running Google searches for things like "Remote Web Workplace application pool unloads minutes" (without the quotes) or similar.
 Advanced Settings
0
DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

 
LVL 4

Expert Comment

by:Scovndrel
ID: 35123596
Also, here's what my "Basic settings" for that app pool look like:
 Basic Settings

If your /Remote virtual directory is associated with some other application pool, that might be the trouble.
0
 

Author Comment

by:mignonnedavis
ID: 35123736
My settings are identical.  I googled around for what you said to, I can find nothing that might help me.
0
 
LVL 4

Accepted Solution

by:
Scovndrel earned 500 total points
ID: 35124283
Bummer. Back to the drawing board. Any event logs messages that correspond with when it stops working? How about IIS logs? Obviously something is going to sleep and waking up when a connection occurs, but not waking up fast enough. Maybe there are some clues in the logs.
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35300706
Did you find the culprit?
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Starting imported SBS2011 as VM in HyperV 14 114
IIS 7.5 to 8.0 6 126
FInd Local Administrators 6 56
Install network Solutions's SSL certificate on SBS 2011 2 36
Because virtualization becomes more and more common, and, with Microsoft Hyper-V included in Windows Server at no additional costs, and, most server hardware nowadays is more than capable of running a physical Small Business Server (SBS) 2008 or 201…
I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question