Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 425
  • Last Modified:

Domain Controller Issue

I have an issue with 2 servers  (which are also a domain controllers).  They are on differenet subnets connected by a hardware based VPN. We have eliminated Networking as an issue. Using packet sniffers (wireshark) on both sides all traffic appears to pass normally in both directions. Packets arrive and are acknowledged. Addtiionally, these 2 server can talk ANY other machines on either subnet without issue.

However, pinging from the Windows command line shows one traffic flowing in one direction only, ie it does NOT show the same results as wireshark. Domain replication only works in one direction, DNS updates one direction, etc.

Have tried removing and re-installed the NICs. Firewalls off on both sides. There are no name resolution issues on either side.

This one is driving me insane. If you need me to post anythig I am MORE than happy too.

HELP!
0
mmcgeehan
Asked:
mmcgeehan
1 Solution
 
Mike KlineCommented:
Any events in the event logs or errors in dcdiag

if you run repadmin /showreps how long since they have replicated.

Thanks
Mike
0
 
mmcgeehanAuthor Commented:
Replication ceased as soon as they were moved to seperate subnets. Placing them back in the same subnet allows replication, in both directions. Bear in mind, even on seperate subnets, replication does work, but ONLY in 1 direction. The event viewer logs and dcdiag logs reflect this as well, i.e. no issues while on the same subnet. I can post the current dcdiag logs (redacted of course) from both sides if you like.
0
 
tmoore1962Commented:
Sounds like a routing issue.  Verify your ACL in the routers linking the subnets.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
kevinhsiehCommented:
How is your firewall turned off? You can't stop the service. Stopping the service enables the firewall. You need to turn it off in the GUI.
0
 
mmcgeehanAuthor Commented:
The Windows firewalls are turned off via the gui on both servers. Its not a routing issue as using Wireshark shows all trafific arrives and is respoded to normally. Additionally, the servers have no issues communicating with any other machines, or the Internet, only with each other.

 I'm going to try another NIC, to eliminate the onboard NIC as the issue. Also, the fact that wireshark is able to detect the traffic, but the OS is not, makes me suspect their is something wrong with Winsock, or the TCP/IP stack, as Wireshark installs its own protocol and shows all traffic arriving and being acknowledged normally.

It is VERY strange. Its not a critical situation at this time as I have 3 DCs and am able to replicate by proxy usiing the 3rd DC.

Wont install the other NIC until Monday at the earliest. I will post any changes, or if it resolves the issues. These are both Dell T310  servers with the onboard NIC (2 interfaces), and I have noted, by searching the Internet, they seem to have frequent issues.
0
 
mmcgeehanAuthor Commented:
Sorry about the delay. The issue still persists. We have put it on hold until the summer when significant downtime can be scheduled. Until then I can work around it, since the secondary problem (replication) is automatically worked out via the 3rd domain controller, which communcates with the other 2 with no issues. So, any changes made on any DC, still get replicated to all 3.

This can be closed.

Thanks All!
0
 
mmcgeehanAuthor Commented:
Well, currently the issue is not pending as we are no longer servicing that customer. However, I ran into an almost identical issue and the soluting was removing an anti virus protocal (AVG) from the NIC. Issue is resolved as far as I am concerned.
0
 
mmcgeehanAuthor Commented:
Accepting this as the answer to my own question. Setting it as C due to not having access to the original server with the issue to confirm the fix would work.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now