Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 685
  • Last Modified:

Write protected; NOT

I have an external drive that I have never "write protected"  but recently I have found it to be so; there is no "delete" option in the drop down and no matter what I do, in Properties/Security,  I get the same results: "write protected".

I've noticed that sometimes to "write protected" warning is on a file; like in this example. write protected example 1  

Other times it is related to another file type, like in this example"
 Write protcted example 2
Am I trying to fix this in the wrong place?
0
mikecox_
Asked:
mikecox_
1 Solution
 
tearmanCommented:
Hit up the Storage Manager and make sure that the drive is online properly.  Try running chkdsk /f until I stops reporting errors as well.
0
 
Randy DownsOWNERCommented:
You maty want to check with vendor site & upload any driver updates. This could be a known problem.
0
 
KCTSCommented:
What sort of drive is it ?
Is is a USB stick ?
If so there may be a small write-protect switch on it.
0
Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

 
Dave HoweSoftware and Hardware EngineerCommented:
if it is ntfs formatted, you may need to "take ownership" of the files before you can delete them.
0
 
Jackie ManCommented:
according to the advice of notsograymatter, it says:-

"It sounds like you pressed the wrong button when booting your computer which changed the properties of the drive.

There's a few solutions I've found on the web:

    * Reset CMOS to optimal settings.

    * Open Regedit and navigate to:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrrentControlSet\Control\StroageDevicePolicies
      If there is a WriteProtect key (REG_DWORD) then
      1 = Write Protect On
      0 = Write Protect Off

    * 1. Go to the disk properties page.
      2. Select the 'Hardware' tab.
      3. In the 'All disk drives' list, select the name of the external device.
      4. Click the 'Properties' button.
      5. Select the 'Policies' tab.
      6. Under 'Write caching and Safe Removal', select 'Optimize for performance'.

Source: http://www.sevenforums.com/hardware-devices/75961-write-protected-external-sata-drive.html
0
 
mikecox_Author Commented:
I got as far as "HKEY_LOCAL_MACHINE\SYSTEM\CurrrentControlSet\Control\"

But there is no "StroageDevicePolicies" just "Storage" which contains one "Default" item.

I checked the link and found that it refers to Win7 and I'm using Vista; which I will be upgrading at the end of the month.

fyi The drive in question is a WD 1200BEVExternal USB Device. Properties show it working "properly". Optimized for "quick removal".  The driver date is 6/06 but I have three of these drives and the other two are not write protected.

I wasn't having a problem with this one until last week.  It appears that I can move files off the drive.  I'm thinking I should moved everything off the drive nd reformatted it; would that reset everything and make this problem go away?
0
 
John GriffithConsultantCommented:
Are you using the "users" user account?  Entries #4 & #5 may trump the Everyone "Full Control".

Add Take Ownership to context menu.  Download - http://sysnative.com/0x8/takeown_icacls_jcgriff2_Windows7_Vista.reg

Allow Registry merge.  Then RIGHT-click on folder/ file, "Take Ownership".

Regards. . .

jcgriff2 MVP
0
 
mikecox_Author Commented:
jc

Before I start messing with the registry let me be perfectly clear about this.  

Clicking the .reg file you included here will cause the files the reg files to merge and add the "Take Ownership" option to the drop down?

Before do that I should backup the current reg file by Exporting it.  I should also set a Restore point so if anything goes wrong I can simply go to the restore point; right?
0
 
mikecox_Author Commented:
I ended up contacting the vendor.  Tech support called and had me plug the drive into my laptop and the delete option appeared.  When I returned the drive to my desktop the drive read "on line" instead of "read only". He said that often happened.   Go figure /-:
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now