SQL 2008 failed to start

I had a similar problem appear as the one discribed in this question:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_26214237.html?sfQueryTermInfo=1+10+30+failur+logon+sql

This error started occuring after I added a second Server 2008 to our first Server 2003 as a DNS and AD server to our network. I receive the exact same error where the password is incorrect and the logon fails. I have tried to follow the instructions to add the administrator user to the "log on as a service" but the "add user or group" is grayed out.

Any ideas why?
hector-martinezAsked:
Who is Participating?
 
BrandonGalderisiConnect With a Mentor Commented:
Have you gone through SQL Server Configuration manager to setup the login, or did you set it up directly through services.  I'm guessing the latter.  There are local windows groups which have accounts added to them properly when using the configuration manager that allow the services to start correctly.  Rather than trying to put the right accounts in the right groups, I recommend configuring services through the config tool that SQL Server provides.
0
 
BrandonGalderisiCommented:
Maybe instead of saying "I had a similar problem appear as the one discribed in this question" and "This error started occuring after I added a second Server...." you could provide the actual error that you are receiving.
0
 
hector-martinezAuthor Commented:
The error is the exact same on as the referenced question and that would be this:

"The MSSQLSERVER service was unable to log on as bbdomain\administrator with the currently configured password due to the following error:
Logon failure: the user has not been granted the requested logon type at this computer.
 
Service: MSSQLSERVER
Domain and account: bbdomain\administrator
 
This service account does not have the required user right "Log on as a service."
 
User Action
 
Assign "Log on as a service" to the service account on this computer. You can use Local Security Settings (Secpol.msc) to do this. If this computer is a node in a cluster, check that this user right is assigned to the Cluster service account on all nodes in the cluster.
 
If you have already assigned this user right to the service account, and the user right appears to be removed, check with your domain administrator to find out if a Group Policy object associated with this node might be removing the right."

When I go to the "Local Security Policies" I can see that the administrator account is not there but the button to add the account is unselectable.
0
 
hector-martinezAuthor Commented:
I was able to start the service with the local permissions as suggested.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.