Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

F2 key not working in Windows Explorer and MS Excel. Fix?

Posted on 2011-03-12
5
Medium Priority
?
1,101 Views
Last Modified: 2012-05-11
My laptop is a Toshiba Portege running Windows 7 Ultimate, MS Office 2010. All updates to all products are current.

In explorer, pressing F2 should open the filename in an edit mode. In excel, it should open the cell in an edit mode. This is not happening.

F2 key itself is working ok - it works fine in other apps.

'Allow editing directly in cells' is checked in Excel.

This is a laptop, with no 'F Lock' key.

'SFC /SCANNOW' shows integrity is ok.

Any suggestions?
0
Comment
Question by:srinikulkarni
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 5

Accepted Solution

by:
Kannan K earned 2000 total points
ID: 35115678
Hi,

Check with your Toshiba Laptop has assigned any action for that key,
check any desktop shortcuts are assigned with F2 key.

KK,
0
 

Author Comment

by:srinikulkarni
ID: 35115706
Thanks, Kannan, but ...
The F2 function is not assigned to anything (nothing happens when I press F2 in Windows). <Fn> key +  F2 is assigned to managing Power Plan, and that works ok.
-sk
0
 
LVL 5

Assisted Solution

by:Kannan K
Kannan K earned 2000 total points
ID: 35115729
Hi,

Search in Registry editor specifying the F2 string key word. It would have assigned with some invisbile shortcuts also.

KK,
0
 

Assisted Solution

by:srinikulkarni
srinikulkarni earned 0 total points
ID: 35115878
Thanks, Kannan.
In the meantime, I tried a brute-force approach: I systematically uninstalled some of the recently installed programs. And it worked. Turns out, Babylon had assigned F2 to one of its operations - which I never used - and because that operation was never invoked in either Excel or Explorer, its behaviour was invisible. Once I uninstalled it, F2 behaviour was restored.
So, it was not the Toshiba laptop but one of the installed apps that had assigned the F2 key for its actions. But your tip helped.
Searching the Registry may have identified the same problem, but in the meantime the problem has got fixed.
Thank you for your help.
-sk
0
 

Author Closing Comment

by:srinikulkarni
ID: 35154467
My comment expands on the expert's suggestion and suggests how it might be extended and applied.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Some code to ensure data integrity when using macros within Excel. Also included code that helps secure your data within an Excel workbook.
You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
This Micro Tutorial will demonstrate how to create pivot charts out of a data set. I also added a drop-down menu which allows to choose from different categories in the data set and the chart will automatically update.

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question