Solved

Quickbooks server manager

Posted on 2011-03-12
43
2,947 Views
Last Modified: 2012-05-11
I'm running QB 2009.  I reloaded my server with SBS 2003.  I can't open QB on any clients unless QB is open on the server.  I have followed all suggestions on the Internet, but to no avail.  QB server management is loaded and running, my firewall is off.
0
Comment
Question by:The_colonel
  • 17
  • 15
  • 10
  • +1
43 Comments
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35117058
ALL suggestions on the internet? How about this one?

http://blog.bruteforcetech.com/index.php/archives/460
0
 
LVL 13

Expert Comment

by:AustinComputerLabs
ID: 35117063
I have used this QB tool to resolve that issue:
http://support.quickbooks.intuit.com/support/Articles/HOW12723

Download here:
www.quickbooks.com/qbdtool
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35117071
I should note, that is my blog. "Experience is what you get when you don't get what you want." I have a lot of "experience" with Quickbooks Database Server Manager. Lately I've had better results, having figured out many of the ways it likes to break, and I posted them in that blog.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35117107
It should work well (I have multiple such installations). So in addition to the above:

1. If you can, uninstall QuickBooks from the server.
2. If you cannot, make sure QB on the Server is set to NOT host multi-user access. There may be a conflict is this is set on.
3. Make sure all client installations are set NOT to host multi-user access.
4. Make sure the server manager is the same version as your QuickBooks client. Make sure the ledger is on the same physical drive as the Server Manager.
5. Make sure you are mapping the clients to the server with UNC paths (NET USE Z: .... )

Check this, and if you can, restart the server. Then restart one workstation and see if you can run the QuickBooks client and connect. .... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35117127
been there, done that
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35117166
If you have the full QuickBooks product installed on the server, then you probably haven't been there and done _ALL_ of that.

It is not necessary nor recommended to have the full QuickBooks product installed on the server - only the Quickbooks Database Server Manager component. The custom setup gives you the option to load either or both. I recommend doing a complete uninstall on the server and trying again.

a. Remove the Quickbooks account from the NTFS folder permissions anywhere that it has put itself.
b. Uninstall the QDSM.
c. Delete the QuickBooks user account (QBDataServiceUser##) from both AD and the local SAM, wherever you find it.
d. Reinstall the QDSM.
e. Tell QDSM to scan the folders where the Quickbooks files are, and let the QDSM reassign NTFS permissions.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35117176
If you have uninstalled QB from the server, then I do not understand your first comment " I can't open QB on any clients unless QB is open on the server".

If all the QuickBooks clients are set to NOT host multi-user access, then the client should open fine.

Without changing anything, find where QBW32.EXE is (probably in Program Files (X86) ). Open a command prompt (with admin access if Windows 7), navigate to the folder where QBW32.exe is, and run QBW32 /nofile. That should force QB to open without a ledger.

1. Can you open QB this way?
2. Now try to open a ledger. What happens?
.. Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35117240
1. QB would not open on any client in multi-user mode until I installed on the server and ran in host mode.
2. QBSM is on the cd as QB install.
3. copied QBSM from C: to D: drive which holds company files, QBSM would not run.
4. drive is mapped.
Basically, everything works fine as long as the server has QB open in host mode, but then I lose one seat.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35117269
Host Mode *conflicts* with the Server manager. It is an alternative to server manager and cannot be used in conjunction with the server manager.

Please go to ALL QuickBooks instances on the client machines, File -> Utilities -> Stop Multi-User Access.
Next, uninstall QB from the Server. Leave the server manager.
Next, open QuickBooks on a client using QBW32 /nofile to get it open.
Next, open a ledger on the server by the Open Company button. Do not use the most recent list at all.

... Thinkpads_User
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35117402
I would modify thinkpads_user's instructions a bit.
Uninstall ALL of the QB stuff from the server, and delete the user account it leaves behind. Then delete any and all files with the .ND extension in the same folders with your QBW files.
Then reinstall JUST the QDSM component on the server, and tell it to scan your QB data folder.

When that's done, do the other steps thinkpads_user recommends, to make sure the workstations are also set up correctly.
0
 

Author Comment

by:The_colonel
ID: 35117535
I know I sound stupid.  Here's what I have.  2 existing clients, 1 new client with fresh load (all XP pro). The new client replaced the client that hosted QB.  The company files were on a server.  Backed up QB to different server with fresh load of Windows server 2003 standard.  Installed QBSM on new server, restored QB.  Opened QB on the new client,  I could only load company file in single user or setup client to host.  The same problem with other 2 clients.  I had to get QB running, so I loaded QB and set it up to host.  I have run Intuit diag and repair, no problems.  I believe I have all permissions set properly(all clients have admin rights).  By the way Intuit and a couple of other experts recommend QB installed on server
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35117589
So to summarize and therefore somewhat repetitive:

1. Unless you are running software that requires it (e.g. Big Time), you should not have QuickBooks installed on the server (Intuit advice notwithstanding). It is bad practice and can lead to the problems you are having. I have several clients with QuickBooks and have had these clients for years). I feel comfortable in suggesting to you that you uninstall QuickBooks from the server. Please do this.

2. Use the Server Manager to scan to for the company file. Please confirm this step.

3. You use the words "to host". Please go to a client workstation, open QuickBooks to no file (qbw32 /nofile). Make sure you do this step so that no ledger (company file) tries to open. You should see a screen with recent files and 3 buttons below the recent files.

4. Now go File -> Utilities -> Stop Multi-User access. Please confirm this step.

5. Now click on the Open Company file button and see that Windows folder window opens. Use this window to navigate to the server location. Open the file. Please confirm this step and let us know what happens.

6. Assuming the file opens, if you are in single user mode, switch to multi-user mode (NOT multi-user access).

I think what is happening is that you have Host Multi-User Access enabled and it should not be when using the server manager. You need to be clear about this part.

... Thinkpads_User
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35117620
It's not that you sound stupid, it's that you don't seem to be taking our word for it that whether you've tried these things individually or not, the QuickBooks multi-user thing is a flaky house of cards, and if one little thing is not right, the whole mess falls down. So rather than poke at one possibility or another here or there, you need to strip the whole thing out and build it all up again, one piece after another, making sure that all bases are covered.

If you want to leave your server logged in all of the time with QB running and the company file open in hosting mode on your server, then go ahead and listen to the folks who told you to do that.

I have QB installed and working perfectly in multi-user mode at four different client sites with about 35 workstations total accessing multiple company files in multi-user mode with just the QDSM installed on the servers, not the full product. That enables the communication to take place whether the server is logged in or not, does not require the full QB product to be installed on the server. If you go through my blog post and thinkpads_user's instructions, you'll get there.

One additional thing to suggest: Move the QBW file and its corresponding TLG file to one local workstation, open it, and set it to NOT be in multi-user mode. Then move the file set back to the server. That way the company file is in a "known" state.

Then turn off multi-user hosting on all of the workstations.

Then uninstall all of QB from the server and delete the user account(s) that were created. If there is a domain account and a local account, delete them both.

Then delete the .ND files, because they may contain incorrect connection information that will screw up the connection even if everything else is right.

Then reinstall just the QDSM on the server, open it, and tell it to scan the folders that contain your company file(s).

Then open the file from one workstation and tell it to switch to multi-user mode (NOT hosting, just multi-user).

If you get all of the ducks in a row, it will work. But you must not take any shortcuts or start in the middle, or skip any steps.

I know we sound repetitive. This is because both of us have been through this a bunch of times, and this is the path to victory. Have faith, follow our instructions, and may the force be with you.
0
 

Author Comment

by:The_colonel
ID: 35117747
except for uninstalling qb from server I followed your steps,  the server manager had already scanned, qb was not in host multi-user access mode.  When trying to switching to multi- user mode I get the H202 error again.  I went through all these steps many times before I installed QB on server.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35117835
So on one workstation, you can open the file (qbw32 /nofile) by navigating to the file on the server and it opens in single user mode. Yes?

Then you change to multi user (without closing the file or QuickBooks) and it gives you an error while switching to multi-user mode. Yes?

Try this:  Copy the company file (.QBW) and its .TLG file to a local workstation. Try to open this file with a QB admin user id and in single user mode. It should readily open. Yes?

Now from File -> Utilities, run a Verify. This may produce an error, so run a rebuild. After the rebuild, follow these steps and try again.

1. Rename the .QBW file and .TLG file on the server to a different name.
2. On the local workstation, remove the read-only attributes from the .QBW and .TLG files.
3. Copy these files back to the server. Delete any .ND files (you may get an errors).
4. Rescan and try again.

In all of this QB on the server should not be running.

.... Thinkpads_User
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35117960
> except for uninstalling qb from server

'nuff said.
0
 

Author Comment

by:The_colonel
ID: 35118000
I uninstalled qb and qbsm from server, deleted all qb users and related files and folders. rebooted, installed qbsm in same folder as company files.  still h202 error
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35118008
Deleted .ND files?
Made sure the workstations all had hosting disabled?

I'm afraid if you've done every step, and run the connection diagnostic tool and it says things are OK, then I'm out of ideas. Intuit really needs to invest some R&D into their multi-user stuff. It really blows.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35118009
Did you try the rebuild step?  There may have been something gone wrong with the company file, but if it opens in single user mode, a rebuild should fix it.

Also note that you might try going to properties on both files (QBW and TLG) on the server and unselect the read-only attribute. Delete the .ND file and try again. The read-only attribute will return and that is OK if it is all working

 ... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35118168
everything checks out. I did all you people said, still h202 error
guess i am stupid. reran network tool. ip reverse lookup status failed, port service status not reachable. firewall is disabled. now what?
0
 

Author Comment

by:The_colonel
ID: 35118170
pinging server comes up with off the wall ip address
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 4

Expert Comment

by:Scovndrel
ID: 35118230
There's your issue - name resolution. Check host records in the DNS server console, make sure there is only one IP for the server name. Delete any extras. Check the bindings in the DNS server properties to make sure that the server only talks to DNS on the correct IP - otherwise it will register RRAS IPs or a second NIC that might have an APIPA address (169.254.x.x).

On the workstations, check that the DNS is set to the local DNS server only - no external DNS entries even as secondary. Clear the DNS cache (ipconfig /flushdns) and ping again until you get the right IP for the server.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35118282
In addition to the above, and also for QuickBooks, you can easily check.

At one workstation, delete all folder mappings. Now map the location of the QuickBooks company file by IP address:  NET USE Y: \\192.168.1.100\server folder (put in the correct IP) and authentic. Now try QB again.
... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35118314
don't have a dns console
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35118339
Go to Start -> Programs -> Adminstrative Tools -> DNS on SBS 2003.  ... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35118935
not there
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35118997
Start -> Run -> mmc <enter>
Add/Remove Snap-In
Select DNS.
Finish it out.
If it does not connect to your server automatically, right-click it and choose a server.

0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35119319
@The_colonel:

First, try mapping by IP address like I said. This will work if it is only a DNS issue.

Now, the more I read about your issue posts, the more it appears that the server needs the operating system properly serviced. DNS is easy to set up - it should have been there, and QuickBooks Server Manager will happily run and work on any properly set up server. That is probably why I did not notice this at the beginning. Do you have an associate nearby who can assist checking out your server?

... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35128285
this is configured as a workgroup file server when windows was installed.  Router is DHCP server.  DNS not needed unless QBSM requires it?  I am the associate. Server has a fresh install.  I think the weird IP address is my ISP supplied address.  
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35128358
So are you saying your server is not a domain? and also not complete with DHCP and DNS?

And then, was this the way it was configured before reload?

I have assumed a domain all along and put my comments forth for Server Manager accordingly. Maybe you do not need Server Manager at all. If it is all workgroup, then uninstall Server Manager and go back to your original post:  Install QuickBooks on the central machine and make it use Host Multi-User Access. Then it needs to be running (as per your first post).

Just remember, you cannot use both Host Multi-User Access and Server Manager at the same time.

... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35129048
mapped with ip address, same problem.  the weird ip address is not from my isp.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35129064
I think you are saying Workgroup (so you are not on a domain) and so not using Server Manager is probably the best approach here.  .... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35129375
The server was a trade-in, I decided to upgrade from my dual pentium 3.  I had hoped to not use up a license on the file server. Sorry for the confusion.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35129419
Thanks for the additional information. I suggest (as noted) to use Host Multi-User Access (as you did and as you said works) and leave QuickBooks running on this server trade-in. Just do not use Server Manager (uninstall it). .... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35129836
On Intuits feature page for QB 2009 states server-client for Windows server 2000-2003 or peer to peer for Windows 2000 or XP. So I'll have to assume QBSM will not work on A peer to peer with Windows Server
0
 
LVL 90

Accepted Solution

by:
John Hurst earned 500 total points
ID: 35130022
Yes. Server Manager is really best on a domain server, so in your case (server but not domain) it will not work well, especially given the way DHCP is set up. Just do not use Server Manager in your case.
... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35130370
Going to load xp on the server and see what happens.  Thanks to everyone for your help.
0
 
LVL 4

Expert Comment

by:Scovndrel
ID: 35131252
Thinkpads_user - You didn't assume, you were misled. From the original post: "I'm running QB 2009.  I reloaded my server with SBS 2003.  I can't open QB on any clients unless QB is open on the server."

I'm done with this thread.
0
 

Author Comment

by:The_colonel
ID: 35131405
Windows server 2003 offers several options for the type of server operation.  I did not know the information would pertinent.  I did not intend to mislead anyone, for that I apologize.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35131800
Thank you, and good luck going forward. ... Thinkpads_User
0
 

Author Comment

by:The_colonel
ID: 35148838
Just to let you know. loading XP made no difference.  Thanks
0
 

Author Comment

by:The_colonel
ID: 35149501
I solved it!!  I disabled advanced dns service on my router
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 35149533
Good to hear and thanks for the update. ... Thinkpads_User
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

By Linda Saltz Customized item descriptions from bills DO import into a customer invoice!   This is a wonderful tip for companies that want to use generic items like Hardware, Software, Mileage, Travel in their item list which helps keep the i…
I was at a customer and we recently set up a new DNS Server.  I asked him to ensure that all servers pointed to the new server.  140 remote servers – estimated 6 days of work to do this manually. Ever had this experience and just need to get the …
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now