Exchange 2007 transition to 2010  - CAS server issue

Posted on 2011-03-12
Medium Priority
Last Modified: 2012-05-11
Exchange setup:
Exchange1 - 2007 sp1 with hub, mailbox roles
ExchangeCAS - 2007 sp1 with CAS role

We are looking to transition to exchange 2010 but I have some issues. I know I need to upgrade my Exchange to minimum sp2 prior to installing 2010 but somewhere along the line the ExchangeCAS server has been running out of disk space, and a disk cleanup has been performed which has got rid of the original exchange installation files, so I am unable to upgrade as it fails on uninstalling the original installation.

So I am wanting to know what my best option is. My thoughts below but apologies for the vagueness - I am trying to give you an idea of what I am thinking to do but feel free to tell me if I am on the wrong track.

Build a new Exchange 2010 client access server and use that. I use a san certificate from Digicert which would allow me to rekey it with the new server name.

Would the new cas server work with the main Exchange server 2007 it being only sp1 or would I have to upgrade that prior to installing the 2010 cas.

Would I have to do anything to point my Outlook clients to the new cas server.

If I cannot uninstall the exchange components from the old CAS server is there a guide to remove it manually from the exchange/ad organisation.

Would my outlook clients automatically pick up the new cas server
Question by:ncht
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
LVL 31

Expert Comment

ID: 35118156
You don't need the original install files to install Excchange 2007 SP2. I would advise you to install E2k7 SP3 though.

Author Comment

ID: 35118242
I have tried both SP2 & SP3 installs.  Both complete pre-requisites and preparing setup phases (stopping services) and then bombs out on the Remove Exchange Files with:

Remove Exchange Files
Unable to remove product with code 24b2c164-de66-44fe-b468-a46d9d5e6b31. This patch package could not be opened.  Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package. Error code is 1635.

This patch package could not be opened.  Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package

LVL 12

Accepted Solution

Dave earned 2000 total points
ID: 35120906
I found one question on here:-


but the answer is not an answer! And there is a long thread here:-


which explains how to replace the missing info. If that fails I think a verbose install and post the log...
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

LVL 31

Expert Comment

ID: 35123737
From the SP3 files try:
Setup.com /mode:upgrade

Author Comment

ID: 35127546

Thanks for the help/links.  Although not the exact answer it set me on the right path so I am going to award the points to yourself. The actual issue was with the rollups installed (which I forgot to put in my original problem - apologies)

The disk cleanup had more or less wiped out the installer folder contents so had to keep trying the upgrade and then checking the ExchangeSetup.msilog. This identified the .msp file which was missing and the expected location of the original downloaded rollup package.

The server is virtual so I could snapshot first and run the upgrade, view the log, download the identified file to the right location and re-snapshot.  Then repeated the procedure for each file until I had all the missing files and it then worked (after clearing space on the C drive)

Lessons learnt:
1. Make sure you provision your drive with enough space (which we do usually to be fair)
2. Be careful what you let the disk cleanup delete (but preferably not have to do them at all)
3. I love snapshots.


Author Comment

ID: 35127583
oops, sorry meganuk3, I meant to say I will award to g4

Author Closing Comment

ID: 35127588
Not the exact solution but led me to the right place.

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question