[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

SSL Certificate Errors on websites using https in IE8

Posted on 2011-03-12
38
Medium Priority
?
1,464 Views
Last Modified: 2012-06-21
I get Certificate Errors on every site that uses SSL. The Certificate Error appears in the Security Status bar (Fig 1). The certificates ARE valid on other sites. I have reset IE. I also went to Tools > Internet Options > Content tab, cleared SSL state. When I click on Certificates I see one that was installed for this user (Fig 2 & 3).  When I click Remove, it prompts saying, “You cannot decrypt data encrypted using the certificates. Do you want to delete the certificates?” (Fig 4). I also started getting this warning in QuickBooks stating, Security Alert: Revocation information for the security certificate for this site is not available. Do you want to proceed?” (Fig 5 & 6).

Any ideas. Images are attached.

Win 7 Pro, SP1 fully updated, workgroup
Cert---Popup-error.GIF
Cert-IE.GIF
Cert---Details2.GIF
Cert-Delete-Warning.GIF
Cert-Warning.GIF
Cert---Revocation-Info-Cert.GIF
0
Comment
Question by:Blue Street Tech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 23
  • 7
  • 5
  • +1
38 Comments
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118523
The article was semi-helpful, but can i remove them without issue? I don't use them for anyting that i know of.
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118529
Is there anything i should do before removing it?
0
Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

 
LVL 30

Expert Comment

by:IanTh
ID: 35118531
as far as I know yes
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118539
It gives me that warning "You cannot decrypt data encrypted using the certificates." what data is it referring to?
0
 
LVL 30

Expert Comment

by:IanTh
ID: 35118596
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118602
I removed it...still get prompted on other websites. checking your link now.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 35118614
Those screenshots are refering to programs that have probably put the certs there.  Leaving them there won't hurt anything.  Have you gone to Windows Update and updated your "root certificates"?  Those are the ones used for encrypting and decrypting data on your network connections.  Also, when you look at "About Internet Explorer", what
cipher strength does it list?  If you're in the US, it should say 128-bit, outside the US it may say 40-bit.  If it says 168-bit, that is a special mode for some federal standard that doesn't work with anything else.
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118624
Hi Dave.

I removed the only one under the personal section...sure hope that does not cause any issues.

Cipher strength says 256-bit.

What should i do so that https works on websites and so that i am not prompted in QuickBooks with the Security Alert: Revocation information for the security certificate for this site is not available?
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118627
I am in the USA too.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 35118643
256-bit is available on Windows 7 but I'm on XP.  Go to Internet Options -> Advanced and make sure that SSL 2/3 and TLS are checked.
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118675
Ok. i did that. Which version of TLS should i check? Attached is what it was set to after i reset advanced settings to default. i will restart IE and test.
IE---Advanced-Otpions---SSL.GIF
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118694
It still prompts me. :(
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118695
I update the system clock as well just to make sure it was not effecting it.
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35118712
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 35119236
In the Advanced tab, I would check them all at this point to see if anything makes the messages go away.
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35119286
i checked them all...same issue. nothing changed after restart of IE.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 35119300
Did you do the "root certificate" updates?
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35119306
WUS has no updates for this PC. There is onlly an optional print driver. that's it.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 35119324
According to http://support.microsoft.com/kb/931125 , it's automatic for Windows 7.  I don't know what else to say now.
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35119355
This has started happening withing the last 2 weeks. I have had WIndows 7 for at least 1 yr now. So something is going on.

Do you think that if i uninstall/reinstall IE 8 that will solve the problem. I dont want to go through the process if it could be something else. Are you pretty positive form what i have told you that it is an IE issue?
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35119443
Would restoring security setting in Windows help. Also, i have noticed that Spiceworks will come up in 404 errors or if page cannot dispay. I say this only if its helpful and may play a part in all of this. Thanks.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 35120028
I don't know if it is just an IE issue.  Other programs often use IE for their own display needs.  You can download Firefox and see if it works ok.  I believe it has it's own certificate store.
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35120038
yeah FF has no issues. but i want to correct this issue if possible. The user needs to use for some reason or another.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 35120060
I guess uninstall/reinstall IE 8 is the next step.  Make sure and reboot in between operations.
0
 
LVL 83

Expert Comment

by:David Johnson, CD, MVP
ID: 35121621
in ie8 when the user gets the certificate error have you tried putting that certificate in the trusted root certificate store?  Firefox allows an exception
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35131136
When the drop down info bar appears i select allow blocked content and then it just repeates the process again. How do I add the cert to the trusted root? is that by installing cert? Thanks!
0
 
LVL 30

Expert Comment

by:IanTh
ID: 35131146
yes
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35131379
i thought it used to give me a button to install cert. Am i missing something? see attachment.
install-cert1.GIF
0
 
LVL 30

Expert Comment

by:IanTh
ID: 35131394
I thought so too
0
 
LVL 83

Expert Comment

by:David Johnson, CD, MVP
ID: 35131767
should have been under general view this screencast http://www.screencast.com/t/HTy1Qp903P6
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35132079
Nope, not in general tab either. see attached.
install-cert---general-tab.GIF
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35132101
What now? Will reinstalling IE fix this?

This is only happening on certain sites with SSL. Not all SSL sites any longer. I think that changed when i deleted the personal certs.
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35133280
I reinstalled IE 8 and it did not fix anything!
Any other ideas?
0
 
LVL 26

Author Comment

by:Blue Street Tech
ID: 35135672
i figured out why the option was not there...it appears that you need to add the site as a trusted site then the button appears. However, it still did not fix the issue after i added the cert successfully.
0
 
LVL 26

Accepted Solution

by:
Blue Street Tech earned 0 total points
ID: 35168719
Thanks Vee_Mod! but I figured it out. I changed the ports from 80/443 to 9675/9676 (http/https) for access to spiceworks. Maybe this is something spiceworks does by design, but it resolved all issues.

Thanks for you help everyone!
0
 
LVL 26

Author Closing Comment

by:Blue Street Tech
ID: 35196734
I figured it out. I changed the ports from 80/443 to 9675/9676 (http/https) for access to spiceworks. Maybe this is something spiceworks does by design, but it resolved all issues.

Thanks for you help everyone!
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Will you be ready when the clock on GDPR compliance runs out? Is GDPR even something you need to worry about? Find out more about the upcoming regulation changes and download our comprehensive GDPR checklist today !
An overview of cyber security, cyber crime, and personal protection against hackers. Includes a brief summary of the Equifax breach and why everyone should be aware of it. Other subjects include: how cyber security has failed to advance with technol…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question