Did I set IP addresses correctly for Hyper-V in Windows 2008 R2?

Greetings.  I'm in the process of migirating a Windows 2003 server to 2008 R2 and also setting up Hyper-V on the 2008 R2 file server in order to run 1 virtual server on it.  I have 2 NICs on the 2008 server.  I've assigned NIC 1 an IP of 10.0.0.5 and set the gateway address.  I'll be using the NIC 2 for the VM.  I installed Hyper-V Role in which turned NIC 2 into the "switch" and also added the NIC 3 Virtual NIC.  I set an IP on the Virtual NIC to 10.0.0.253 with no gateway address, and also set it to NOT register itself in DNS.   I then installed my virtual server and assigned it's virtual NIC to 10.0.0.9 with a gateway address.  The virtual server will be running GFI Web Monitor Stand Alone Proxy.  Everything appears to be working fine.  I believe I did everything right.   HOWEVER, when I connect to the 2003 server to do file transferring I see in the 2003 management console connected sessions that the 2008 is connecting using the 10.0.0.253 address and not the 10.0.0.5 of NIC 1.   Why would this be?  Is it because the binding order in the advanced network properties is NIC 3 - NIC 2 - NIC 1?     Can I change that to NIC 1 - NIC 2 - NIC 3?   Maybe I'm not doing something right.   I would really like that 2nd onboard NIC to be strictly used for the virtual server.
debbiezAsked:
Who is Participating?
 
kevinhsiehConnect With a Mentor Commented:
Yes, uncheck allow management operating system to share the network adapter in the virtual network settings on the host.
0
 
debbiezAuthor Commented:
Forgot to mention both the old and new server are just member servers.
0
 
debbiezAuthor Commented:
Think I found the solution.  Had to uncheck allow management operating system to share this network adapter.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.