Solved

ActiveReport.arrCacheItem 404 Error

Posted on 2011-03-12
1
1,686 Views
Last Modified: 2012-06-27

Issue:
When attempting to use arrCacheItem we are getting a 404 error (screenshot):
Server Error in Application "SITE - 8010"
Internet Information Services 7.5
Error Summary
HTTP Error 404.0 - Not Found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
Detailed Error Information
Module      IIS Web Core
Notification      MapRequestHandler
Handler      StaticFile
Error Code      0x80070002
Requested URL      http://localhost:8010/site/PaymentDetail/857809533_2122276674_1234766842_1538925457/ActiveReport.ArCacheItem

Physical Path      D:\Inetpub\site\Claims\PaymentDetail\857809533_2122276674_1234766842_1538925457\ActiveReport.ArCacheItem
Logon Method      Forms
Logon User      <snip>
Failed Request Tracing Log Directory      C:\inetpub\logs\FailedReqLogFiles

            

Versioning:
•      ActiveReports 6.2.3164.0
•      Windows 2008 R2 Web Edition
•      IIS 7.5
•      App Pool for Site is set to .NET v4 Integrated

Web.config has the following:

System.Web Handlers:
    <httpHandlers>
      <add verb="*" path="*.mvc" validate="false" type="System.Web.Mvc.MvcHttpHandler, System.Web.Mvc, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL" />
      <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" validate="false" />
      <add verb="*" path="*.rpx" type="DataDynamics.ActiveReports.Web.Handlers.RpxHandler, ActiveReports.Web, Version=6.2.3164.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
      <add verb="*" path="*.ActiveReport" type="DataDynamics.ActiveReports.Web.Handlers.CompiledReportHandler, ActiveReports.Web, Version=6.2.3164.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
      <add verb="*" path="*.ArCacheItem" type="DataDynamics.ActiveReports.Web.Handlers.WebCacheAccessHandler, ActiveReports.Web, Version=6.2.3164.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    </httpHandlers>

System.webServer Handlers:
<handlers>
      <remove name="MvcHttpHandler" />
      <remove name="UrlRoutingHandler" />
      <add name="MvcHttpHandler" preCondition="integratedMode" verb="*" path="*.mvc" type="System.Web.Mvc.MvcHttpHandler, System.Web.Mvc, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL" />
      <add name="ReportViewerWebControl" path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
      <add name="ar rpx" path="*.rpx" verb="*" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,runtimeVersionv2.0,bitness64" />
      <add name="ar cache" path="*.ArCacheItem" verb="*" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,runtimeVersionv2.0,bitness64" />
      <add name="AR" path="*.ActiveReport" verb="*" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,runtimeVersionv2.0,bitness64" />
      <!--<add name="ImageHandler" verb="GET" path="*.image" type="Univita.TransitionCare.Web.Handlers.ImageHandler,Univita.TransitionCare.Web"/>
      <add name="CredentialImageHandler" verb="GET" path="*.credentialimage" type="Univita.TransitionCare.Web.Handlers.ImageHandler,Univita.TransitionCare.Web"/>-->
    </handlers>

We have tried many different combinations of 64-bit, 32-bit and both within Web.Config to no avail – what you see above is our current settings.

We referenced the information here to no avail:
http://www.datadynamics.com/Help/ActiveReports6/arHOWSetupIIS7ForActiveReportsProjects.html

Thank you for your prompt assistance!
0
Comment
Question by:CodexK2
1 Comment
 

Accepted Solution

by:
CodexK2 earned 0 total points
ID: 35129925
This issue was solved by following steps indicated here:

http://www.datadynamics.com/forums/135180/ShowPost.aspx
0

Featured Post

Active Directory Webinar

We all know we need to protect and secure our privileges, but where to start? Join Experts Exchange and ManageEngine on Tuesday, April 11, 2017 10:00 AM PDT to learn how to track and secure privileged users in Active Directory.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

An enjoyable and seamless user experience can go a long way on an eCommerce site. While a cohesive layout and engaging copy play roles in creating a positive user experience, some sites neglect aspects that seem marginal but in actuality prove very …
There’s a good reason for why it’s called a homepage – it closely resembles that of a physical house and the only real difference is that it’s online. Your website’s homepage is where people come to visit you. It’s the family room of your website wh…
This video teaches users how to migrate an existing Wordpress website to a new domain.
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question